
  

 
  EccoMagic 

 MagicViews       
    Gather Information & Take Notes  
 

 
Introduction:   
         There used to to be a cool program called "NetSnippets" which saved webpages (including 
graphics) and sort of allowed some kind of outline structure. But it wasn't a real outliner,  and very 
soon,  all those web pages got out of hand. 

If you can't find your info... you don't have it! 

        Which problem led to this very special tool.   Instantly enter notes and clip information from the 
screen, the web, Word, Excel, PDFs, E-Mails, etc.,  and place into an outline where you can access the 
information, move it around, and organize it!    

        The best, (and maybe only), way to have control of your information is to have it organized.  
Traditional 'key word search' techniques or crude outline lists don't let you do that.  MagicView does. 

        It is worth skimming over all of the instructions even if the complexity of options seems at first 
overwhelming.  Once you're ready to jump in,  conceptual getting started hints are here and,  at the 
EccoMagic forum there are examples and tutorials that are worth the time to look through and think 
about.  That site is located here.  There is also  a 'Help overview'  at end of the help text  (Control + 
End), and you can press  Alt + X for the help index at any time. 

        If the screen is too small and you're viewing these instructions from within an Ecco sidebar,  you 
can F1 out of the instructions, resize and F1 back, or press F11 to toggle full screen view.  You can 
also press control + minus to reduce the font size ( and control + plus  to  increase it ). 

  

        Some things you can do with MagicView: 

 Use your viewpages as part of your integrated outline, including auto-
dating, full labeling and auto-assignments,  and with full technical 
outline control and flexibility. 
 

 Copy from your viewpages directly to outline sub-items, and visa versa. 
 

 Enter notes directly and clip from just about anywhere, including 
graphics from the screen and quick audio notes. 
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 Freely attach multimedia files or other objects (JPEG / PNG / GIF / BMP / 

WAV / WMA / WMF / MP3 / MPEG / AVI / SWF / MP4 / PPT / PDF / 
DjVu / DOC / XLS / EML / MHT / ETC.), as the viewpage of any item. 
 

 Comfortably save over a billion characters of text and a virtually 
unlimited amount of graphics in over 30,000 view pages per ecco file. 
 

 Seamlessly secure your text with Microsoft AES 192/256 bit strong 
encryption (requires XP/Windows 2003 or higher). 
 

 Send your live or saved MagicView page (from any source) directly to 
your browser or instantly jump to the original source document. 
 

 Save your pages either within ecco or seamlessly in an external disk 
folder.  

 Grab a selection of pages and flip through them all together. 
 

 Share the same note/viewpage between multiple items. 
 

 Share clips among multiple networked users in real time.   Clips from the 
web, Word, Excel, Email, etc., can be viewed and edited on networked 
systems--  even if the system does not have that software installed. 
 

 Link directly from any viewpages to any other. 
 

 View a page and all of its linked pages together as one. 
 

 Export one item or as much of an outline as you select. 
 

 Export any/all view pages in outline format to a web browser viewable 
tree, seamlessly including viewpage graphics, PDFs, DjVu, MP3s, media 
files etc.  
 

 Export timelines with timeline dating. 

 Search in Ecco and see a manageable results screen. 
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        While still being able to: 

 Append to, export, and print your saved  clips.   
 

 Modify, and easily mark up your saved clips,  with super easy to use 
 

 Highlighting, 
 

 Indexing, 
 

 Private notes & comments, 
 

 Cross-page hyperlinking, 
 

 Outline cut & paste integration, 
 

 Block math,  and 
 

 Flexible outline numbering. 

 
 
        Hopefully too, MagicView feels at home. 

        MagicView is fully compatible with your existing Ecco files.  For those who have used a 
NoteEdit/EditNote plugin with "RTF" notes,  you can instantly use existing notes by simply renaming 
the note folder to "MagicView_1"  and enabling the RTF option in the File menu.  The MagicView 
notes are not only more compact and much more powerful as notes,  but are secure and open the 
door to true information gathering and organization fit for the information age. 

        Just like in Ecco's main outline, Control + K opens your text formating window.  Tab indents your 
outline level.   Most every command has a hotkey shortcut. Control + Q is there to instantly insert 
the date & time, and even the "<" and ">" navigation butons work exactly like the "Prev" and "Next" 
buttons in Ecco's form view dialog.   

        MagicView integrates deeply into the Ecco workflow on many levels.  For example, selecting and 
moving information from MagicView to ecco items is as easy as pressing Control + Alt + C  to 
instantly copy the current MagicView selection as a new Ecco child item. 

        Using Ecco MagicView you can move around, organize, and access huge blocks of data using 
very small tag lines.  You can have Hundreds of Megs of data, and yet have ecco orderly, responsive, 
and downright fun to use. 
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  Adding content:    

 
Overview:  You can gather information in MagicView in over 30 different ways, 
including: 
 

 Hotkey Clip directly from anywhere directly into MagicView 
 

 Hotkey Clip directly from web browsers into Ecco 
 

 Clip screen shots directly into MagicView or Ecco 
 

 Dictate Quick Audio Notes 
 

 Cut from anywhere, and Paste into MagicView 
 

 Drag & Drop into MagicView from: 
 

 Sections of Web pages 
 

 Selections from thousands of supported programs 
 

 Entire HTML, RTF, or TXT files  (thousands can be added at the 
same time) 
 

 Photos 
 

 Program and data files to create links 
 

 PDF, DjVu, MHT, EML, and similar file types to create seamless 
links 
 

 Multimedia files such as MP3, AVI, MPEG, WMA, WMF, MP4, SWF, 
WAV, etc., to create live view seamless links 
 

 Zip files or even disk folders to create 'live' attached folder views 
 

 and more... 
 

 Attach seamless links to files using a 'Load Disk File' dialog 

  

Additionally,  clips and/or clip images and multimedia or other files (on the local 
computer, network,  or the internet) can be: 
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  seamlessly 'linked' to ecco items, 
 

 Most file types simply dropped into MagicView (via the 'ItemText' 
box) are attached as seamless links. 
 

  'grounded' and stored in a special .web folder linked to the .eco file, or 
 

 Holding down the shift key when dropping most fily types, attaches 
them as 'grounded' objects,  saved locally in the ".web" folder linked 
to ecco. 
 

 Alt + G  will 'ground' most file types (and images of viewpages). 
 
 

 stored internally within a .eco file. 
 

 Holding down the shift + control keys when dropping  generally 
attaches files internally in the ecco file. 
 

 Native MagicView pages are stored in ecco internally.   Control + 
Shift + G  will 'ground' native MV pages and store them in the .web 
folder (along with the page's images). 
 

 Most other objects can be moved to internal ecco storage via Control 
+ Shift + G.  
 

 Intenal storage is allowed for files up to about 6 Megs per item,  
however,  it is generally recommended to not to internalize files over 
256k or so, (as the data transport time to retrieve the data becomes 
lengthy).  A maximum of about 1.8 Gigs of data can be internally 
stored in a single .eco file,  subject to global pointer availability. 

  

Finally,  view pages can be stored unencrypted,  or encrypted for a specific user.  
(An unlimited number of users and password can be used with file encryption). 
 
 
 
 
  Adding clips to a MagicView page:   

  

A) From your browser, word processor, spreadsheet, pdf viewer, or other information 
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source, simply drag & drop a selection into MagicView. 

 
NOTE: 

1. Hold down the Ctrl key when copying from word processors such as MS 
Word. (Otherwise the text is 'moved' to MagicView, instead of just copied 
over.  If this happens,  you can press Ctrl + Z in MagicView to restore.) 
 
2. Multiple cells from Excel are as much as possible kept as a table,  in most 
cases,  just like they showed up in Excel. 
 
3. In most cases, you can also drag from MagicView directly into Word, Excel, 
etc.. Please note the same caution applies-- hold the control key down when 
you release the drag to copy the selection. (Otherwise,  you will move, ie. 
delete in MagicView, the moved selection. If this happens, you can restore the 
selection in MagicView with Control + Z.) 

4. Dragging & Dropping is easy,  but does not store the location of web-pages 
from where you dragged.  To save the location of the information, use a direct 
clip to MagicView,  or copy & paste with 'saved URL'. 

5. Images on web pages are most often 'links' to images which show the 
image.  Dragging such an 'image' to the MagicView page will drag the link, not 
the actual image.  In other words, in this case the image shown is not saved 
locally unless you explicitly ground the page (after adding the image(s) to the 
MagicView page).   

6. Similarly, if you drag a web image to the ItemText box,  you'll generally see 
an error message that the image can't be found.  That is because the 
temporary cache used to show the image is temporary. 

7. The instructions assume "Magic" mode (button in upper left hand corner).  
You cannot add or modify a page in "View" mode.  (There are other 
indications as well, the color of the item text line at bottom, is green for Magic 
mode and red for View mode.  "MAGICview" appears in Magic mode, 
"magicVIEW" in View mode.) 

  

B) Drag & drop graphics, text, PDF, DjVu, and HTML files, as well as disk folders 
directly into MagicView's ItemText box. 

Simply drag any graphics, txt, or html file to MagicView's ItemText box while holding 
down the Control key (or Shift).    
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Note: do not drag to the MagicView page display area for this feature, drag to the 
ItemText box at the bottom. 

  

 In addition to files, individual graphics images can be dragged directly to the 
ItemText box from most browsers.   
 

 If dragged from a web browser the image will be treated itself as a 
viewpage,  just like a PDF, DjVu or similar file dragged from disk.    
 

 If dragged from a disk file, the image will be treated as an image link 
added to the viewpage.  To manually add an image link for an image on 
the web,  use the Alt + P function to insert an image link into a viewpage 
by pasting the image's URL. 
 

 A viewpage must be 'grounded' if you desire to save the dropped 
images locally.   You can save all of a view page's images locally by 
grounding the page (after you have inserted the images) and a page 
can be grounded multiple times if desired. 
 

 Only a single image from the web can be dropped as a viewpage for any 
one ecco item,  as compared with the magicview screen clip which 
allows adding multiple images to the same viewpage (and 
which automatically grounds the clips), or as compared with manually 
adding the image link,  or selecting the images in the browser and 
clipping that selection. 
 

 Drag & dropped text, rft, emdf, and html files are incorporated into the 
viewpage text directly when dragged to the viewpage itself, or when the 
control key is held down when the files are dropped to the ItemText box.  
Multiple files can be dropped at the same time to the ItemText box. 
 

 Drag & dropped text, rft, emdf, and html files dropped to the ItemText box with 
the control key not pressed will be added as sub items of the active item.  If 
the shift key is pressed when the items are dropped, the new items will be 
stored in the .web folder. 
 

 With PDF, DjVu, EML, MHT files, disk folders, etc.,  holding down the control 
key has the opposite effect-- the pdf will replace the active page unless  the 
control key (or shift key) are pressed (in which case a new item will be 
created).   The PDF, etc., file will be linked,  that is, the file on disk will be 
displayed but not saved as a part of the viewpage.  (You can 'ground' the 
page to make an extra copy of the file saved as a part of the viewpage in the 
".web" directory.)   For detailed instructions on adding MHT, EML, PDF or 
DjVu files, see the 'Adding PDF and DjVu Documents' section below. 
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 Multiple files, even thousands and of multiple types,  can be added at the 

same time.  (You can add up to 30,000 grounded attachments per file, or up to 
about 1.5 Gigs of internalized files). 
 

 Multiple EML, MHT, PDF and DJVU files will be linked to new subitems but all 
other graphics files (dragged from disk) are incorporated directly into the 
viewpage (when added with the control key is held down).   You can drag and 
drop literally hundereds, or even thousands of files at the same time. 
 

 Note: If text, rtf, or html files are dragged to the ItemText box without holding 
down the control key, the files will be added as sub-items using the file's 
names. You can mass import rtf, text, and html items this way.  (When viewing 
RTF imports,  be sure that the 'Use RTF' option is selected in File > Folder 
Options ). 

  

C) Copy,  and paste the clip into MagicView 

        On the Edit menu, you'll find three pasting choices. (You can access the Edit 
menu by clicking the "Edit" button, by  pressing Alt + D,  or by right clicking and 
selecting Edit.) 

        1.  Control + V ,   paste. 

        2.  Shift + Control + V,  paste and save clip css and source information. 

        3. Winkey + Control + V, paste and save clip css and source as a clean, new 
page.   This will erase any clips or information currently in the active MagicView 
page. 

Note: pasting with clip css and source information may take a moment or two 
to process (especially with extremely large clips, or clips that require reading 
other files in order to determine css context). 
 
 
 

D) Hotkey Clip directly into MagicView. 
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In most any program, mark the section you desire to clip, and press  Winkey + 
F12.  
 
There are a wide variety of clipping options, and to help keep things relaxed, the 
'master' hotkey Winkey + F12 is always available to provide a convenient menu of 
clipping options.  You can also hotkey clip directly: 

 
Winkey + Control + C   ('Add Selection to viewpage')  to append  the clipped 
selection to the current  MagicView page, 
 
 
Winkey + Control + Shift + C  ('Replace viewpage > with Selection')  to replace the 
current MagicView page with the clipped selection. 

  

Notes:   
 
        1. If you accidentally erase a MagicView 
page with the Winkey + Control + Shift + C 
function, if you activate MagicView and press 
the same key command (Winkey-Control-Shift-
C) within about 6 seconds, the page will revert. 
 
        2. If you copy from scientific or non-
English sources, this clip method may work 
better than creating a new item from clip text.  
Ie., First manually create a new ecco item (or 
use an existing one),  and load that item as the 
current MV page (Alt - Right Click on ">" 
navigation bar  or Winkey + /   )   and then use 
the Replace viewpage clip.    With this method, 
the language/font setup is established when 
you first load the blank item,  and can be less 
'confused' by a clip from non-English source.   
Some experimentation will reveal the 
distinctions. 
 
 
Also note:  
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Winkey + Control + Alt + C  ('Replace viewpage > from URL')  to replace  the 
current MagicView page with the webpage referenced  in the current selection.   

For example, highlighting "google.com" (in any program) and pressing Winkey 
+ Control + Alt + C  will replace the active MagicView page contents with the 
contents of the webpage found at "http://google.com". 

  

Winkey + Alt + C   ('Add Selection and Images')  to append  current selection to the 
current MagicView page, and, store any images locally. 

Saving Web graphics:  

Web and similar clips that include graphics will also include the graphics 
when pasted.  The normal mode for this is to display the graphics from 
the original location.   The advantage to this is speed and space-- no 
space or time is used to download, copy or store the image.  This is the 
best way to clip and view when the information we are after is textual.  
The text is stored forever,  and with very little overhead,  the images are 
initially available as well. 

The disadvantage to not storing images locally is that images and 
locations may change in the future.  For images that are more than just 
convenience,  images which themselves are information we want to 
save,   the safest bet is to save a local copy of those images.  To clip 
directly into MagicView and to save a local copy of any web page 
images,  use this alternative clip. 

Note: 

        There are insertion hotkeys which do the 
opposite of the Winkey + Control + C  and 
Winkey + Control + Shift + C  hotkeys: 
 
        Winkey + Control + Insert  will insert 
slected text from the active viewpage into the 
currently active window. 
 
        Winkey + Control + Shift + Insert will 
insert the full text of the active viewpage into 
the currently active window. 
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1) Images are saved to a directory located where your  .eco file  is 
located,  named the exact same as your .eco file, but with ".web" as the 
directory's extension.   Java applets, external scripts, embedded 
movies, etc.   are not stored locally.   

2) If you want to store a page's external java applets, etc., use your web 
browser to save the webpage ("complete") in the appropriate directory, 
and then browse to the saved file,  and clip from that file into your ecco.   
The page, including scripts, will be a part of your .eco file and always 
accessible to you-- so long as the directory and source files are 
accessible.  

3) If you relocate your .eco file,  move the .web folder as well.   If you 
change the name of your .eco file,  you can manually rename the .web 
folder,  or allow MagicView to handle that automatically as part of its 
error and checksum procedures.  

4) Storing images locally requires having an actual file to link them to.  In 
order to use the MagicView image storage feature you must first open 
an ecco file.  (A new ecco session that is not yet saved as a file is not 
sufficient-- there is no file to link the images to.)   Ecco does not need to 
display an open window,  but Ecco must be running, with an actual file 
open as the active session. 

 
The purpose of MagicView is information gathering,  and when photos 
are actually information (such as diagrams, etc.)  it is extremely helpful 
to be able to clip the photo info as well.   However, making a 'backup' of 
webpages for 'history'  is not a helpful way to gather and organize 
information.  Suggested that you save images when it is really 
necessary.   Keep in mind that it is the information you are after,  not the 
presentation.  (Some web browsers are text only!). 

  

You can also manually localize (save to disk) photos from any web clip, at any 
time,  by pressing Alt + G to 'ground' the clip.   

Ie., if you dragged & dropped a clip you can immediately (or later) use 
the 'Ground" command to save the clip's images locally. Grounding a file 
will also localize the 'CSS' style sheets for any webpage.. 

Keep in mind that grounding is not necessary for text clips or when 
you've clipped using any 'with images' clip type.   Any clip can include 
images, just that the image's aren't saved locally unless you clip 'with 
images' or use the Alt + G ground feature. 
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Keep in mind also that when you attach djvu, Doc, PDF, and similar files 
(by dragging to the Item Text box) the files are attached to the ecco 
item, but are not copied to the .web folder.   If you want to include the 
file in the ecco file's .web folder,  you can Alt + G ground the page after 
you have attached the file.  Or, before attaching the file(s) you can copy 
them to the ecco file's  .web folder (located in same directory as the .eco 
file,  with the same name and the .web extension [you can even create a 
subdirectory in the .web folder and place the files there]) and then drag 
the files from the .web folder  to the Item Text box. 

  

  

Note:  The above clips modify the active viewpage  attached to whatever 
Ecco item that viewpage is attached to.  These clips are very helpful for 
building a viewpage from mulitiple sources.   There are other clips for 
creating new viewpages for the clip.  (Items clipped directly into Ecco are 
indicated by five dots following the item text ' ::. ').  Options from the 
standard Winkey + F12 menu which  create new  viewpages attached to 
new Ecco items: 

 'Selection as New item'  , 'Selection and Images as New item' , 
and 'Selection's Page and Images to as New Item' to add  the 
current selection as a viewpage of a new  Ecco item. 
 

 'New item from URL'  to add  a new  Ecco item with a viewpage 
of the webpage referenced  in the current selection. 
 

 Holding down the "Shift" key when selecting "New from 
Url" to prevent automatically ground the new clip.  (Ie. not 
to save the clip's images locally). 
 

 'MHT link item from URL'  to add  a new  Ecco item with linked 
MHT file from the viewpage of the webpage referenced  in the 
current selection 
 

 Holding down the "Control" key when selecting this option 
will save the MHT internally in the Ecco file, instead of as a 
linked file saved in the ".web" folder. 
 

 Holding down the "Shift" key when selecting this option will 
allow selecting a location to store the MHT (or EML) file. 
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E) Hotkey Screen Clips 

 
1)  Winkey + Shift + F12  to capture a screen clip directly into MagicView.   

 As with 'Grounding' clips, to use the MagicView screen clip feature you 
must first open an ecco file.  (A new ecco session that is not yet saved 
as a file is not sufficient-- there is no file to link the images to.) 
 

 Ecco does not need to be displayed on your desktop as an open 
window,  but Ecco needs to be running, and the active 'file' needs to be 
a real file,  not a temporary 'Untitled' view. 
 

 How to Clip: 

1. Activate the clipping tool by pressing Winkey + Shift + F12. 
2. After activating the tool, move the cursor to the upper left, or 

lower right corner of the desired clip area. 
3. Press and hold the left mouse button, and select the 

desired clip area.   
 

i. To reset the corner of the clip area you can press and 
release the control key while still holding down the left 
mouse button. 
 

4. Release the mouse button to clip normally to MagicView.   
  

 Your clip will be saved and inserted at the cursor position in 
MagicView. 
 

 The MagicView window does not need to be open to clip. 
 

 Once clipped, screen shots can be copied and freely pasted in other 
MagicView pages. 
 
 

2) Winkey + Alt + F12 to capture a screen clip directly to Ecco. 

 Saves the clip at the currently active ecco item. 
 

 The screen clip is stored as an ecco item,  not as a viewpage. 
 

 This type of clip is stored directly inside of the ecco file. 
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You can drag & drop,  copy & paste,  screen clip, or mark & clip  
directly into MagicView multiple clips from web browsers, word 
processors, Excel, etc., etc. 
 
Marking & clipping direct from most web browsers, saves additional 
information about each clip including the source.   When viewing clips 
captured this way (or captured by clipping directly into ecco),  you can 
instantly jump to the original page source(s) by pressing Alt + O.   
 
Drag & drop and screen clipping do not allow later being able to  jump 
back to the original source for webpages, (but drag & drop does still for 
Word and Excel clips). 
 
So, if you want to capture the content of a webpage,  drag & drop 
works great.  If you want to capture also the location of a 
webpage,  and be able to use Alt + O to instantly jump to the original 
clip source(s), use Winkey + Control + C. 

  

  

 
  Adding web clips directly to ecco:    

 
Overview:  You can clip directly from the web to any ecco file.  Most web browsers 
are already supported (Internet Explorer, Firefox, Maxathon, K-Meleon, Opera, 
etc.), if yours is not,  we will add it.  With most modern browsers, clips are saved 
along with the location from which they were clipped. 

  

A) Mark and clip directly into Ecco 

 
1)  Winkey + Shift + E   ('Selection to New item')  to paste the current selection as a 
new viewpage attached to a new item in the currently active .eco file. 

a. Clips are pasted as siblings to the currently active item,  unless the item 
is a TLI (top level item), in which case the clips are pasted as children of 

Page 14 of 80MagicView



that item. 

2) Winkey + Shift + G  ('Selection and Images to New item') paste the current 
selection as a new viewpage attached to a new item in the currently active .eco file 
with any images in the selection saved locally in the .web folder. 

a. If not displayed,  MagicView will open automatically to allow review of 
the page after saving clipped graphics locally ("Grounding" the file).  
Some web pages will not look nice after grounding.  (For example, 
pages built internally by javascript, etc.).   

 You can explicitly 'ground' any page (ie., save locally the css 
and graphics attachments) from the File menu, Ground tool.  
(or use the Alt + G shortcut).    This applies to pages created 
by drag & drop,  pages previously saved without saving 
graphics locally, etc. 
 

 You can load a webpage directly from its source (if clipped 
with source information) using the File menu, Load Clip 
Source tool.   (If you want to save the page once loaded,  be 
sure to save it,   loading a clip source does not automatically 
re-save the page.) 

b. To paste directly into the "WebMagic Inbox" folder instead of at the 
currently active item,  use Winkey + ALT + G from within your web 
browser.   This option is shown from the Winkey + F12 menu  ('New in 
WebMagic Folder > Selection and Images')  when a recoganized web 
browser is active. 

 Winkey + ALT + G from within Ecco will optionally 'link' a 
particular file for 'WebMagic" clips.   Ie., using Winkey + Alt + 
G from within a web browser, ill save to the  "WebMagic 
Inbox" folder in the linked file,  regardless as to what file (if 
any) is currently active in Ecco. 
  

c. If the page does not display as you desire, (eg., the area copied did not 
include hidden formatting info, etc.),  from MagicView you can press Alt 
+ Shift + O to directly load the page into MagicView from the net.  If that 
looks good,  then use Alt + G to ground the new page contents. 
 
Some pages will not allow themselves to be copied by either of these 
approaches.  In that case,  use the web browser's built-in "Save As 
Complete Web Page" or equivelant command to save the page to disk,  
and then use Alt + Shift + L to load into Magic View. 
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3) Winkey + Control + Shift + G  ('Selection's Page & Images to New item')  to paste 
as a new Ecco item with the selected text as the item text, and an attached 
viewpage of a fresh reload of  the clipped from webpage page with any graphics 
saved locally. 

a. This clip works well in many cases where you want to clip an 'exact' copy of 
the original web page.   

b. In some cases this clip will not work as 'expected' because a fresh reload of 
the desired page may result in a different webpage then the page actually 
clipped from.   This can be caused by many issues,  such as javascript page 
redirection,  page trapping,  security issues with the server, etc. 

c. The page may look different in 'Magic Mode' than displayed in your 
browser.  'Viewer' mode more closely duplicates the 'look' of your web 
browser. 

  

4) Winkey + Control + ALT + G  ('New in WebMagic Folder > Selection's Page and 
Images') to paste directly to the 'WebMagic' folder of the active .eco file, a fresh 
reload of  the clipped from page with any graphics saved locally. 

 Ie. this is the same as  3) Winkey + Control + Shift + G,  except it saves 
to the WebMagic folder instead of at the active ecco item. 

 
  

 

B) Mark, position, and paste into Ecco 

 
You can clip from your browser,  and then go to Ecco and paste the clip. 

How to do it: 

1) Mark the desired section in your web browser.  

 You can even mark text, graphics, or both. 
 

 You can even mark everything with Control + A. 
 

2) Press  Winkey + Control + E   ('Capture selection')  from within the browser. 
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3) Go to ecco and find where you want to paste the clip.  Select (for example, 
single click) the item. 
 
 
4) Press Winkey + Control + E   ('Paste captured clip') again from within Ecco. 

 To also save any clipped graphics,  paste in Ecco with Winkey + 
Control + G   ('Paste clip & Save Images') instead. 

  

  

 Usage Note:   

When I find something in my web browser that I want to save, 
use Winkey+Control+E to clip it,  then go to ecco, and find where I 
want to paste it . 
 
Once selected in ecco where to paste,  Winkey+Control+E inserts 
the clip immediately below (as a 'sibling'')  the actively selected 
item, or as a child if the selected ecco item is a top level item.   
 
When there are multiple clips to paste under thesame parent in 
ecco, use Winkey+Shift+E to paste directly from the browser into 
ecco-- at the currently active ecco location.  
 
 
To view saved pages,  simply use Winkey +  / . 
 
To view the 'Phonebook' entry page for any item, use Winkey + 
 Control + / . 
 
To review saved pages,  also use Winkey + <  and Winkey + > 
(actually "," and "." keys which on my keyboard are also "<" and 
">" ). 
 
F5 also makes flipping back and forth betweenpages super easy 
(as does Alt + <  and Alt + >). 
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C)  'Specialty' Clips 

 
Overview:  MagicView provides several 'specialty' clips for gathering 
information from the web directly to an ecco outline.  To use these 
commands, simply mark the desired portions of any web page,  and 
press the hotkey combination.  The clip is inserted in the active ecco 
file,  at the currently active item.  (Ecco needs to be running, but does 
not have to be showing in order to clip.) 

  

1) Winkey + Shift + Alt + E   the  'most recent clip with history' tool.   

 This will replace any existing clip for that item.  Ie. this is the one 
kind of clip that is 'dangerous' in that it will silently erase an item's 
clip. 

Be careful with this feature it replaces the clip of the active 
item with the new clip.  

 A text copy of the new clip is also attached as a child of 
the new clip item. 

 This tool allows you to search for something specific 
(for a specific item), clip it if you think you've found it, 
 and then instantly update if you find that it is 
something else you really wanted.  A history of your 
clips (as textual sub items) is kept for easy and instant 
reference. 

  

2) Winkey + Shift + Control + E   the 'full text' tool. 

This will clip a full text version as a child (sub item) with an attached 
links list. 

  

3) Winkey + Alt + E   the 'collection' tool. 

Clips to a special "WebMagic Inbox" folder instead of adding to the 

Page 18 of 80MagicView



currently selected location in ecco.   This tool allows for clipping now, 
and sorting out later.  

  

Technical Note: 
 
Clipping directly to Ecco creates auto entries in folders "URL" and 
"MagicView?", and if an auto date folder is set up in your ecco file,  the clip 
date will be stamped in the autodate folder as well.  Also, If the "OnDisk 
folder" is enabled (Configuration > Advanced Folder Options) auto entries in 
the folder "MV onDisk" are created for any pages stored in the '.web'  folder. 
 
The URL folder contains the web address from which the clip was clipped. 
After about 10,000 clips, a new folder "URL2" (and then "URL3") is used.   
(The MagicView install creates a launch tool to allow right-click launching of 
the URL folders.)    
 
The Webclip? folder is checked if there is a MagicView page associated with 
that item.  Adding a MagicView? column to your view,  makes it easy to see 
and to filter for items with MagicView attachments.  
 
Folders named "Magicview_1" - "Magicview_256", "Magicview_1B" - 
"MagicviewB_256", and "MagicviewC_1" - "MagicviewC_256" are also created 
based on the number of viewpages, and maximum viewpage size in any file.   
 
 
Note: Setting the above folders to 'public' or not in shared/networked ecco 
files will determine if MagicView pages are shared or private. 
 
 
If you have clipped more than 15,000 entries to any single ecco file with 
datestamping enabled,  you should rename the datestamp folder,  turn off 
date-stamping for the folder,  and create a new auto-date stamp folder for 
fresh clips. This is important because date folders can only have 16,383 item 
assignments, and file errors/freezing of file will be generated when that limit is 
exceeded.   (This applies to all items and files, not just MagicView.   For more 
information and tutorial see "HOW DO I FIX MY OVERFILLED AUTO-DATE 
FOLDER" in the EccoMagic forums.) 
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  'Exact' HTML content clips:    
 
 
 

Overview: Sometimes you may want parts of a webpage that you can't 
normally copy, such as specialty background color settings, etc.  There 
are several ways to 'capture' exact HTML content with MagicView.  

 
  

A) Hotkey any URL selection.  

 
1) Select a valid URL in *any* program.  

 For example, most browsers provide an URL edit field.  
Highlight the URL in that field. 
 

 With web pages hidden behind a referrer URL or topframe,  the 
displayed URL most likely will not be the actual URL to the page 
you desire. (In that case,  clip a section of the page, and use the 
Shift + Alt + O page reload feature.) 
 

2) Press Winkey + Control + Alt + C  ('Replace viewpage > from URL')  to 
replace the content of the currently active viewpage 

  

3) Select 'New from URL'  from the  Winkey + F12  menu to save a new 
viewpage from the selected URL. 

 Holding down the 'Shift' key when selecting "New from Url",  will 
prevent automatic grounding the URL's page.  Ie., so that 
images will be not be saved locally in the .web folder. 

  

4) Select  'MHT link item from URL'  from the  Winkey + F12  menu to 
save a MHT file of the selected URL.   
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 Holding down the 'Shift' key when selecting "MHT link item 
from Url",  will prevent automatic grounding of the URL's 
MHT.  
 

 Conversely by holding down the 'Control' key and 
selecting "Cancel" when prompted for the MHT file 
name, the MHT will be automatically grounded.   (In 
this case the MHT file name will be assigned 
automatically and you can leave the name box empty). 
 

 Holding down the 'Control' key when selecting "MHT link 
item from Url"  (or holding down the 'Shift' key and selecting 
"Cancel" when prompted for the MHT file name) will save 
as a child of the active item the URL's page as an internal
MHT in the .eco file.   If the MHT size is over 6.1 Megabytes 
the URL's page will not be saved.  This option is best used,  
if at all, for pages without extensively large graphics or 
'flash' content. 
 
 

 Holding down the 'Shift' key when selecting "Save" at the 
same MHT file name dialog will generate an automatic 
email of the page for direct sending.   (Then, simply click 
"Forward" to send).   This option works when used alone, or 
in combination with the other file name modifier key savings 
options.   

 
  

B) Drag & Drop raw HTML from the web.  

 
1) Access the raw HTML from your browser.   

 Most browsers provide an option to view the HTML 'source', 
either in the File or Edit menus,  or by right clicking on the 
webpage. 
 

 With framed web pages,  you'll likely need to view a frame's 
source for the actual HTML. 

2) Toggle MagicView to rawHTML mode by accessing the option in the 
View menu, or using the Alt + R shortcut hotkey.  
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3) Mark the desired HTML in the browser's source viewer. 

4) Simply drag and drop the HTML portions you desire into MagicView. 

5) Toggle out of rawHTML mode (Alt + R). 

  

  

C) Drag & Drop a saved webpage file.  

 
1) You can drag & drop .txt and .html files directly into MagicView. 

 
  

D) Load a webpage directly from a file.  

 
1) From the File menu, select "Load New File" to load any .htm or .html 
file as the active MagicView page.  

 Alt + Shift + L is the hotkey shortcut.  

 
  

E) Load a clip's original webpage, directly from the Web. 

 
1) The clip in the active MagicView page must contain the source 
information of one or more clips. 

 All direct to Ecco clips and most MagicView clipping methods 
include the source information. 
 

2) From the File menu, select "Load Clip Source" or use the Alt + Shift + O 
hotkey shortcut. 

 If the active page contains clips from more than one source,  
you will be prompted to choose the source you wish to load. 
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 If you want to save the page's  graphics locally,  ground the 
newly loaded page by choosing "Ground" from the file menu, or 
the Alt + G shortcut. 

  

Note: 
 
        Alt + O opens the original source externally from many 
source types (eg. a webpage will open in the browser, a 
Word document will open in Word, etc.) and is used to 
open the original of all clipped sources outside 
of MagicView. 
 
        whereas 
 
        Alt + Shift + O is used only when the original source 
was a webpage, and replaces the MagicView Page with an 
exact copy of that webpage.   

  

  

 
  Adding PDF, DJVU, EML, MHT, MP3, AVI, SWF and other documents or 
multimedia:  

 
Overview: Links to 'Objects' such as EML, MHT, PDF, DJVU, MP3, AVI, 
SWF, WAV, MPEG, etc. documents and multimedia can be saved to 
provide seamless viewing with MagicView.   The objects can be located 
anywhere, including any file's .web folder.  (Object viewpages can be 
localized or 'grounded' just like any other MagicView page.)   

Setup Note:  

        1. For objects to be viewed properly in MagicView the default 
system association for the file type must be properly set in 
Windows.  In most systems the configuration is already properly 
setup.  Typically these associations are set in the "File Types" dialog 
of different default file handlers.  Windows media player, for example, 
allows setting such associations (to the default media player) via the 
media players'  Tools > Options > File Types dialog. 
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        2. Similarly, the core 'Active-X' modules must be properly 
installed for viewing documents types such as PDF and DjVu.  If your 
system can properly view these types of pages over the web,  your 
system is most likely already properly configured.  If not,  you'll need 
to install the (free) 'Active-X'  or browser plug-in provided by the 
official distributor,  e.g, Adobe, LizardTech, etc. 

        3. For viewing AVI files in MagicView,  the appropriate 'codec' 
needs to be available.  If not,  you might for example see a black 
screen instead of the video. 

  

A) Drag & Drop .pdf, .djvu, .mp3,  or similar files to the MagicView ItemText 
box  (or Button Strip).  

 
1) You can create an 'empty' MagicView page by clicking on any ecco 
item (even a new one) and pressing Winkey + /  (or right clicking on the 
">" Navigation button [and selecting 'Load from Active' if View > 
Navigation Menus is selected]).   You can drag & drop to an empty page's 
ItemText box, or to an existing viewpage's ItemText box (to replace that 
page's content). 

2) If a single file is dropped,  that 'object' is made the current MagicView 
page.   

NOTE: Dragging & Dropping a single file does not automatically save 
the object in your ecco file.  You will still need save the page with 
Control+S  or other save operation.   If you 'ground' the page "Alt + 
G" the page will be saved and the dragged file will be copied to the 
'.web' folder (so long as File > Folder Options > Ground local files  is 
selected). 

3) If multiple files are dropped,  each 'object' is added as a child item of 
the currently active ecco item.   Ie. With multiple files,  each file is 
automatically saved as a new ecco item. 

  

NOTE: To add an object, drag to the MagicView Button Strip (where the 
buttons are located), or to the ItemText box,  and not to the actual 
MagicView page area.  
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B) 'Grounding' PDF/DJVU/EML/MHT/MP3 and other attachment files.  

 
1) Attachments dragged to the 'ItemText Box'  initially are merely linked to 
the .eco file.   So long as the attachment file is located at its original 
location and with its original file name,  everything works fine.   To insure 
access to a copy of the attachment,  you can manually 'ground' by 
pressing Alt + G while viewing the attachment's viewpage.    After 
grounding,  a dedicated copy of the attachment located in the  .web 
folder associated with the .eco file is linked to ecco. 

 
To Ground when adding attachments hold down the shift key when 
dropping the files into the 'ItemText' Box. 
 

  

  

2) MagicView allows you to store attachments inside of the .eco file itself.  
Unless you have a very particular reason for doing this,  this is not 
generally recommended.   Your ecco file can quickly get huge this way and 
searches for folder values start to take a long time.   NOTE: Internalized 
attachments which are extremely large will take up to 30 seconds to load 
when viewed in ecco.  In most cases,  grounding is a superior approach to 
internalization.  (The maximum file size that can be internalized is set at 
6.1 Megabytes. However, much small files (up to 60k),  are more 
appropriate for effective use internalized.)   

To store an attachment inside of ecco,  while the attachment is active, 
select in ecco the item you want to hold the attachment and press Alt 
+ Shift + G.  

 
To Internalize attachments when adding them, hold down the shift 
and control keys when dropping the attachments into the 'ItemText' 
Box 
 

  

  

3) You can also export a MHT version of a viewpage directly into the .eco 
file.  The MHT attachment  include the viewpage's images, java, etc.   
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(This is not recommended unless you have a very good reason for it.   
You cannot edit MHT files like you can viewpages,  and saving many MHT 
files can fill ecco with 100s of megs of data).   You can save about 1,500 
one meg MHT attachments inside of ecco,  whereas you can save 30,000 
MHT attachments or viewpages stored in the .web folder.   

To export a viewpage into Ecco as a MHT attachment,   use the 
File > Export to MHT function, but instead of entering a file to 
export to hold down the shift key and click on "Cancel"  (Alt + 
Shift + S).  The export will then be directly to the .eco file.  

  

 
  Adding Links to other MagicView pages:    

 
Overview: Links to other MagicView pages (in the same file) can be freely 
added.    

  

Winkey + Control + P  to create a link to the currently active item (in the 
same file as the MagicView page). 

 The Link will be added to a text section if selected. 
 

 Winkey + Alt + P to insert the link which was 'grabbed' in Ecco by 
pressing Winkey + Alt + P from within Ecco to 'grab' a link to the 
active ecco item. 

  

NOTE:  

 Activate the link just like any other-- Clicking on the link (in 'View' 
mode)  or Alt + Clicking on the link in Magic Mode.   
 

 To view a page and all of the page's links,  use File > Load > Load 
Linked Items  or Alt + Control + L .    The pages linked to those 
pages can be added to the active page by repeating the command,  
or pressing again Alt + Control + L . 
 

 Links can be manually modified using the Alt + H hyperlink shortcut 
key. 
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  Sharing MagicView pages among items ("Mirroring") :    

 
Overview:  MagicView Pages  can be shared between ecco items.  For 
example, the viewpage of a phone book entry can be attached to children of 
multiple project items.  Modification of any of the mirrored pages modifies 
them all.   

  

Winkey + Control + S   

 
Attaches a 'mirror' of the current viewpage to the active ecco item (in 
the same file). 

Also available via the File Menu (File > Save > Mirror at Active). 

  

NOTES:   

1) Items to which mirrored pages are attached can be freely 
deleted.  If the master item is deleted so are the mirrors, unless 
the page's data location is disk storage. 

2) MagicView's 'fail safe' page saves (when you for example, 
open a new viewpage before saving changes to the current 
page) occur in the background in order to make page loading 
faster.   If you forget to save a mirrored viewpage and then load 
the same viewpage via another item which shares the mirror,  
the page initially loaded will be the 'proper' unsaved page.   If 
you then save the modified page (via prompt,  or automatically if 
'QuickView Autosave' is active)  the page you were looking at 
will be the prior version of the mirrored paged.  This is an issue 
only where (1) you modify a mirrored viewpage without saving it 
and (2) immediately view the same viewpage via a different 
ecco item.  In this case, MagicView will automatically update the 
viewpage when a background save impacts, (or might 
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impact) upon the page you are currently viewing. 

  

ADVANCED USER NOTE: For advanced users, viewpages can be seamlessly 
shared among multiple ecco files.  You may encrypt any or all of the shared pages.  
This is a powerful but advanced feature and requires a special disk structure for the 
data file directories.  Here is how you do it:  (This will make much more sense if 
you've already spent some time reading the rest of the manual, and after trying 
different features such as storing pages to disk,  using the navigation buttions, etc.) 

  

a. Use the File > Folder Options > Cross-File Shared Folders > .web Folder 
Override dialog to designate any file's .web folder to be the same as any 
others'. 
 

b. Be careful compressing shared .web folders: 
 
i. To compact your combined/shared .web folder use the File > Folder 

Options > Cross-File Shared Folders menu. 
 

ii. First 'Compress the shared .web folder'  for each of the .eco files 
sharing the data. 
 

iii. When you've done that for *all* of the .eco files involved, then 
"FINALIZE the compression". 
 

iv. NOTE: Failure to follow this procedure when compressing 
shared .web folders will risk data loss. 
 

c. For extra protection,  you can 'Mark .web folders as shared' from the 
Cross-File Shared Folders menu.   This will help MagicView prompt you 
for possible mis-steps and can help save you from losing data. 
 

d. For extra safety,  no data is actually deleted outright.  Data is sent to a 
'trashbin' folder in the .web folder,  so you can save offline and then delete 
in safety. 
 

e. To share a viewpage across multiple ecco files, you must set the page to 
be stored on disk.  Then add the page  to any item in any file sharing 
the .web folder. (eg, open another file sharing the same .web folder,  
select any item and RIGHT click on the LEFT "<" MV navigation tab [if the 
Navigation menu is active select the 'Mirror at Active' option].   Or, use the 
EccoMagic! (Classic) 'Copy with folder values" feature to simply copy the 
ecco item (with folder values) to the new file.  This will add the 'mirrored' 

Page 28 of 80MagicView



cross-file viewpage to the new file.) 
 

f. A change to the viewpage by any of the shared files will change the 
viewpage for all.   Deleting the item attached to a shared viewpage does 
not delete the viewpage for other files. 
 

g. To 'unjoin' files simple copy all  of the files (including subdirectories) from 
the shared .web directory to a new folder.  Once done,  run for each file 
"Compress Attachments Folder"  from the File > Folder Options menu.   
That's it.   You can delete the trashbin sub folder to save data space/clear 
unwanted data. 
 

h. In setting a .web folder override, you can set the folder path to be fixed or 
relative to the location of the .eco file.  If you move an .eco file with a 
relative folder override,  the .web folder is expected to be placed in the 
same folder structure relative to the .eco file. 
 

i. No data is copied to the new .web folder location when setting up a .web 
folder override.  If you have data in the .web folder when you create a 
folder override,  you must copy the files in the .web folder (and subfolders) 
to the newly designated folder. 

  

  Saving content:    

Overview:  Unless an autosave interval is explicitly set (File > Folder Options > Autosave 
Interval), clipping content to a MagicView page does not automatically save the content.  There 
are helpful options as to where and what to add to the ecco file.   

 
  
  Page Storage Options:   
 
 

One of the key functions of MagicView is saving view pages directly in Ecco.  
You can clip over a Gig of data,  up to 8 Megs per clip this way.   (Most clips 
stored this way will load faster than other programs which could be used to 
capture web snippets such as NetSnippets and MyBase).    

MagicView also has the optional ability to seamlessly store view pages to disk 
in the ".web" folder.    These pages can be virtually unlimited in size,  and 
stored encrypted or unencrypted (just like other view pages).   The size of 
these pages is not added to your .eco file,  but the page content cannot be 
searched via ecco.   As far as MagicView is concerned the chosen location of 

Page 29 of 80MagicView



viewpage is seamless, and can be freely changed simply by saving a page.  
(The page is saved based on the page and default settings for storage.) 

  

Per page Storage options  

  

Winkey + P access the page properties dialog allowing instant selection of 
disk or ecco based storage for the active page.  Encryption for the active 
page can be selected at the same time. 
 
Winkey + O will save the active page to on disk storage (in the .web 
folder). 

Winkey + control + O will save the active page to ecco internal storage. 

  

Global Storage options  

  

Via the File > Data Location  menu a forced default storage location can 
be choosen.    
 

 If a forced location is active it will override manual selection of the 
storage choice for any viewpage.    
 

 |) will appear by the Item Text box if forced storage to disk is active.   
 

 (||) will appear if encryption is also set as the default. 

 
 
 
 
  Attaching (Saving)  to the active Ecco item:   
 
 

 The following functions operate on the current, actively selected Ecco item. 

 Ecco does not need to be displayed in order to attach a MagicView page. 
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 The active ecco item may be a different item, or in a different ecco file,  than 
the ecco item the page was originally viewed from. 
 
 

A)  Hotkey  

 
1) From within Ecco, or MagicView pressing Winkey + Shift + / will attach 
(Save) the active page to the active ecco item. 

  You can also select "Save at Active" from the File menu,  or use the 
Control + Shift + S hotkey shortcut. 
 

  This is the only way to copy viewpages which are stored on disk 
(.web folder) to another .eco file.  Viewpages stored in ecco can be 
copied directly to other files using the EccoMagic! (Classic) tool's 
"Copy with folder values", available here. 
 
 
 

B)  Mouseclick 

 
1) Right click on the left arrow navigation button  " " . When navigation 
menus are enabled, Alt + Right click will save the page directly. 

  

 
  Saving a item's modified MagicView page:   

 
Overview:   When an ecco item's MagicView page is viewed,  you can freely 
modify and then re-save the page,  even if you are no longer positioned on the 
original ecco item,  and even if you have changed the active file in ecco.   (Re-
saving to the original source item requires that the original file be at least still 
loaded into ecco.) 

  

A)  Shortcut Hotkey 

 < 
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Control + S saves the active MagicView page to the item a MagicView page 
was last viewed from.  

a) It does not matter what file or item is active in ecco,  so long as the 
file containing the original item's file is still open (ie. clicking on ecco's 
lower right "Files" button shows the file in the open file list). 
 
b) When you view any item's MagicView page,  or "Save as Active" a 
MagicView page to any item,  that ecco item is linked to the active 
MagicView screen.   Control + S will always save to that item. 

  
Winkey + S saves the active MagicView page and the Ecco file it is attached 
to. 

  

  

  

B)  via Menu selection 

 
From the File menu, select "Save". 
  

 Note: Menus can be accessed by 
 

 Clicking on the menu button (right click for 'quick access 
menus); or 
 

 Pressing the menu's Alt key shortcut; or 
 

   File menu        Alt + F  
   Edit menu       Alt + D  
   Format menu  Alt + T  
   View menu      Alt + V  
   Indexing          Alt + X 

 
 Right clicking on the MagicView page. 
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  Attaching pages to multiple ecco items:   

 
If multiple ecco items were viewed together (a 'multiView'),  you have the option 
of saving the multiView, or a modified page to all of the items at once. This is 
useful, for example, to fill template values over multiple items.  

Note: 

 Saving (with Control + S or via the menu) will save the current page 
to all of the items actively loaded.    
 

 If you want to modify a single item in a multiView, use Alt + L to lift 
individual item for editing, and saving. 
 

 To save a multiView to a new item,  use Control + Shift + S,  or 
another 'new item' saving option.  

 
 
  

 
  Saving to a new Ecco item:   

 
When a new item is created to hold the active MagicView page,  the item text is 
copied from the "Item Text" box at the bottom of the MagicView window.  The 
active MagicView page can be saved as a new child, or as a new sibling of 
either (1) the currently active ecco item,  or (2) the currently active MagicView 
page. 

  

1)  (Optional) Set the "Item Text" box text to the desired item text 

Note:  

 
 1) You can toggle the size of the Text edit area by: 
 
        (A) clicking on the "Item Text" label,  or  
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     (B) right clicking on the Item Text edit box and selecting 
"Item box sizing".  
 
 
 2) Control + Shift + I  will copy marked text from the MagicView 
page to the Text edit area.  
 
 

  

 
   

2)  Create a new child or sibling item. 

 
Note: 

Use "Save Under Active"  to save relative to the current active 
item in Ecco,   or  

Use "Save under Viewpage" to save relative to the current 
MagicView page item. 

 
Select: 

"Save as Child"  to save as a child   or   

"Save as Sibling"  to save as a sibling. 

  

 
   Available shortcuts include: 
 
  Winkey + S                           Save MagicView page and Ecco file
 
 
  Alt + S          

 
 
Save as Child of current MagicView page 

 
 
  Control + Alt + S          

 
 
Save as Child of Active Ecco Item 
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         or, Right Click and select File menu,  (or Alt + F  File menu). 
 
  

  

 
  

  

 
  Saving Ecco item text content:   

  

Overview: Currently there is no way to save or modify formatting of Ecco item 
text.  For that reason,  MagicView is designed to avoid as much as possible 
any modification of the Ecco item text itself.  The following are functions which 
allow you to create or modify ecco item text from within MagicView. 

  

  Copy Text to Child. 

  

Control + Alt + C will copy the text selected in theMagicView Page to a 
new child of the currently active ecco item. 

  

The 'Contiguous Copy to Child'  option (View > Configuration) enables copying 

  Winkey + Alt + S         Save as Sibling to current MagicView page 
 
 
  Winkey + Control + Alt + S    

 
 
Save as Sibling of Active Ecco Item  

 
NOTE:  Saving a page as a child or sibling makes 
the newly saved to item the active MagicView page 
item, (except when saving siblings of the 
Viewpage). 
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the selected text as a contiguous block of text. 

  

Important Note:    

'Save at child' and 'Copy Text to Child' create a new child at the 
CURRENTLY SELECTED ITEM IN ECCO,  regardless of which file or item 
the original MagicView Page is attached to.    
 
Whereas,  'Copy  Text  to  Item',  copies  the  selected  text  as  the  new  item 
text for the item with which the MagicView page is attached to, regardless 
of which file or item is currently selected in Ecco. 

  

  Copy to Item Text.  

  

Control + Alt + Shift + C  will replace the MagicView page's item's text with: 

  

A) The text selected in the MagicView Pane,  or,  

  

B) if the Item Text Line is selected/active in MagicView, the text in the 
'Item Text' box.  

  

Winkey + Control + Alt + Shift + C will restore the original item text.  Ie., essentially 
'undo'.   

  

  

Note: 

'Copy to item Text' will instantly replace the item text of the item to which 
the MagicView page is attached-- regardless of what file or item is currently 
displayed or active in Ecco. 
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You can add/modify the text to an Ecco text item,  but ALL the text 
formatting within the item will be lost.  For this reason extensive editing of 
Ecco text from within MagicView is not recommended.  

Text formatting that applies to the first character of the item will be applied 
to all of the text added/modified by MagicView. 
 
Three dots " :. " at the end of an ecco item indicate the text was copied 
from the viewpage text. 

  

  

  Copy to Ecco 

Control + Winkey + Insert    will directly paste the current selection into ecco. 

Note: If you hold down the shift key when selecting Copy to Ecco from the 
copy menu,  or  if you use the Right Winkey,  multiple lined text will be 
combined on a single line,  and a space added to the end of the paste. 

  

  

 
  Exporting viewpage content:   
 
 

Overview: You can export, and even directly email viewpage and multi-
view content including images and formatting.  

  

Exporting text, formatting and graphics to a single MHT File 

 
To export a viewpage or multi-view to a MHT file,   use the File > Export to 
MHT function,  (Alt + Shift + S).    By selecting a file name ending in 
".eml"  you can use the same function to export directly .eml email files. 
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Exporting as email and  instantly sending 

 
By selecting a file name and then holding down the shift key when clicking 
on "Save"  (Alt + Shift + S).  The export will then be directly to an .eml file,  
and if supported by your system,  an email dialog will be activated.   
Simply click "Forward"  to send the viewpage.    

In most email programs the email received will look exactly like the 
viewpage or multi-view the email was exported from,  including graphics 
and formatting. 

 
  

Exporting a Group of items 

 
To export all or part of an outline with MagicView pages in a tree outline 
format, use File > Export Group (Alt + Shift + Winkey + S). Standard MV 
pages will be exported in MHT format,  other document formats (such as 
pdf, djvu, etc.) will be exported with original file formatting retained.    

Simply: 

1. Select in Ecco the items desired to be exported.   Only items 
explicitly selected (ie., no unselected  children, etc.) will be included. 
  
2. From the MagicView pane, select File > Export Group  or press Alt 
+ Shift + Winkey + S. 

3. Select a folder location for the export (you can press Shift + click 
on Cancel  to select a folder location based on the system's root 
structure).  The main file export will be to a "MVImages" folder 
created in the selected export Folder. 

  

Options: 

From the Control + F1 configuration menu: 
 
 

"List Mode"  will truncate large item texts to 256 characters. 
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(Note: Exported item text is otherwise limited to 1024 characters 
per item.  You can add a file "MVExportLength.ini" to the 
magicview.exe folder specifying a different maximum 'standard 
mode' length if desired.) 
 
 
"Export to HTML" will export native MagicView pages as HTML 
pages with grounded images in one folder per MV page.  (Note: 
Pages which include grounded images clipped from web 
browser are 'published' for use at a non-portable destination 
when exported with this option.) 
 
 
"Export Dating" will add the date value for each item from the 
first  date column in the notebook view. 
 
 
"Export Numbering" will add basic outline numbering to the 
exported tree. 

  

Notes: 

A. Each export session is assigned an unique ID number as part of 
each export file name, and each exported file is sequentially 
numbered in original outline order. 

B. The file named #####-index.html located in the selected folder is 
the primary index.   

Clicking " • / + " will collapse/restore an item's sub-outline (like 
double click in Ecco).   

Shift + Click will collapse/restore the item's children (like Ecco 
Control + J).   

Holding down the Control key with either of these will apply the 
action to the remainder of the tree view.  (E.g., Shift + Control + 
Click  ). 

C. The file named #####.html located in the MVImages folder is a 
secondary index, and may be accessed directly. 

D. Exported file names can be manually designated prior to exporting 
by entering the desired name in a "Name'EM" folder for each or any 
item. 
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E. Selections from the Calendar or PhoneBook are not merged into a 
combined outline-- each new entry is treated as a top level item the 
same way it appears in the Calendar or Phonebook.  Selections from 
other views are merged into a new outline based on the items' 
position in the actual outline. 

F. To be able to view the exported pages, the viewing browser must 
be configured to display MHT files (or at least have MS Internet 
Explorer compatibility mode).   To view exported .djvu, .pdf, graphics, 
video clips, etc.,  the browser must be Active-X enabled  and the 
appropriate viewing agents must be properly installed.  Access 
to collapsing outline functionality within the tree view requires that 
Javascript be enabled in the viewing browser. 

 
  

  Encryption:    

 
MagicView uses MicroSoft's AES 192/256 bit strong encryption.  This is good if you 
want military grade encryption,  but not so good if you lose your password, or are 
running older OS such as Windows 2000.  (MS AES strong encryption will work only 
with XP, Windows 2003, etc.,  and newer OS).   

Page encryption is seamless,  so that an encrypted page once loaded can be edited 
and freely resaved encrypted as the original. 

  

Use  File > Encryption > Page Encryption  (or Winkey + P )   to  activate  the 
encryption & storage options for any viewpage.   

  

Pages set as encrypted are encrypted with the currently active user password at the time 
the  page  is  first saved.   To  change  the  active  user  for  encryption,  use  File > 
Encryption > Clear Password to clear the current password.   When the page is first 
saved after choosing  to activate encryption  for  that page,   if  the active user password 
has been  cleared  (or  not yet  entered)   you will  be prompted  to  enter  a user  name "," 
password.    

If  you  enter  a  username  followed  simply  by  a  comma  (",")   you  will  then  be 
prompted  for  the  password  but  the  entered  password will  be masked  so  others 
viewing the screen (or capturing screen images) cannot see the password entered. 
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The longer the password the more secure.  Note: a comma cannot be included in 
the user ID, but *may* be included in the password itself. 

Each  user  ID  should  usually  have  a  single  password.   Ie.,   encrypting  different 
pages  with  the  same  user  ID  but  different  passwords  is  possible  but  not 
recommended.   By using a single user  ID/passord for each user,  the encryption 
will be seamless--  the user will be prompted one  time (when  the first encrytped 
page  is  viewed  or  saved)  and  that  user's  encrypted  pages  will  be  seamlessly 
viewed  and  saved  until  the  password  expressly  cleared   or  auto-cleared  (by 
entering an  interval in seconds when manually clearing the password). 

Lost passwords cannot be retrieved.  Store them in a safe & secure place (perhaps 
an encrypted MagicView page). 

  

Important notes: 
1. Any localized files (from the file's .web directory) included in encrypted pages 

are 'exposed'.  Neither the local files nor the file names are encrypted.   To 'hide' 
local files included in encrypted pages,   simply use links to files in a directory 
other than the '.web' directory for that ecco file.  Ie. everything in a secured page 
is encrypted, except  for the names of any localized files attached to that page.   
If you attach files not located in the official .web directory,  there is no way for 
anyone to know that any files are attached to the page, or where or what files 
might be attached. 
 

2. Multiple users can save encrypted pages within the same .eco file,  with each 
user's password being unique.    
 

3. You cannot as a realistic matter recover a lost password.  If you need to recover 
lost data,  we can attempt a 'brute force' attack to discover the password and 
recover your data.   Depending upon the length of the password, assuming you 
used only the charachers A-Z in the text of your password, discovery of the 
password will take several hours to several decades.  As the range of possible 
characters increases, so does the time involved-- exponentially.  (Note that as 
with any protection based on passwords,  a short & simple password can be 
figured out by software 'brute force' attack.  Even a longer, more complex 
password (more than just A-Z used as characters) is likely not beyond the range 
of a supercomputer.) 
 

4. Please be careful with encryption.  If you encrypt and forget your 
password,  even if you pay for data recovery, and a machine set up dedicated to 
that task, it could take a long time to see your data again.  ( If you lose a long, 
complex password,  there is no realistic hope to recover your data during our 
lifetimes.) 
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5. As with browsing web pages or viewing Word documents, system cache files 

may contain a copy of the contents viewed.  To avoid this,  use a cache 
scrubbing program, and/or, use a program like PGP and save an encrypted 
version of your notes in MagicView,  and use only the PGP secured viewer to 
decrypt and view.   Ie. Since MagicView relies upon Windows to display 
graphics, etc., normal windows cache locations may contain traces of what was 
viewed. 
 
Note: Unlike programs like MyBase, MagicView does not save a copy of your 
pages to disk,  nor load them via Microsoft's normal page cached loads. In this 
respect there is a much higher degree of security, but,  memory is not locked 
against paging,  and there could be traces of what you view. 
 
  

6. Mass Encryption. 
 

a. Default encryption (for advanced users).   It is possible to set up a 
default template which automatically encrypts.   (See more on default 
templates below.)  Simply include "<META EMCRYPT>" after the 
"<HEAD>" tag in your default template form. 
 

b. The "Always Encrypt" feature.  (File > Encryption menu) 
 
i. While activated ALL pages are saved encrypted, but 

the encryption is not 'seamless'.  The  next time the page is 
saved or edited it will not be saved encrypted unless 
manually set to encrypted or the "Always Encrypt" option is 
enabled at that time.  The purpose of this is to avoid data 
loss-- saving encrypted data  without realizing it. 
 

ii. If you load an encrypted 'Always Encrypt' page, and save it 
with Always Encrypt off,  the page will save as a normal, 
unencrypted page.  By contrast,  a page manually set to 
"Page Encryption",  is 'seamless'  and will automatically be 
re-saved encrypted. 
 

iii. An * is displayed next to the Item Text box when default 
encryption is active. 

  

  

  Navigation Buttons:    
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The Navigation buttions are multi-function buttons,  providing different tools based on click 
combinations.   In  addition  to  the 'combination click' operation of  the navigation  buttons,  if 
the View > Navigation Menus option is selected  right click (without any click modify key 
being  pressed)  on  either  Navigation  Button  will  activate  the  navigation  menu  for  that 
button.    Every  navigation  button  function  (other  than  'load  previous'  and  'load  next'--  the 
unmodified left click function of each button) can be selected. 

  

 

        
 
 

 < 

Left Click     Load previous item in Ecco file

  

  

Right Click 

  

 
  

  

Save page to currently active Ecco item 

also  via Alt + Right Click 

or 

Navigation menu when that option active 

Shift + Left Click Add previous item in Ecco file 

  

Control + Left Click 

  

Jump to previous item of a multiView 

Alt + Left Click Move back in page view history

  

Shift + Right Click 

  

Save page (at orginal location) 

  

Shift + Control + Left Click 

  

Mirror page at active Ecco item 
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Control + Right Click   

  

Share page with another MagicView session 

 > 

Left Click     Load next item in Ecco file 

 
Right Click 

  

Load active Ecco item 

also  via Alt + Right Click 

or 

Navigation menu when that option active 

  

 
Shift + Left Click    Add next item in Ecco file 

 
Control + Left Click 

 
Jump to next iem of a multiView 

 
Alt + Left Click  Move forward in page history

 
Shift + Right Click 
 

Reload page 

Shift + Control + Left Click Insert link to active Ecco item

 
 
Control + Right Click  

 
 
Get page from another MagicView session
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  Viewing & Editing content 

 

  QuickView 

 
Overview:  QuickView allows for the quick viewing and editing of the MagicView pages 
for any ecco item in the active file.   The MagicView page of the current Ecco item is 
automatically displayed in MagicView.   QuickView can be activated for all files or a single 
ecco file.  (Remember,  you can always manually load view pages for items with Winkey 
+ /   or Winkey + Z,  or right click on the right navigation button.)   

Note:  Most pages load quickly, but extremely large pages may take a moment or two to 
load. 

  

Press Winkey + Q to activate QuickView from MagicView or Ecco. 

(You can also activate QuickView via the File menu) 

  

Press Winkey + Shift + Q to activate QuickView for the active file only. 
 

If you switch files with the QuickView single file option activated, the feature will 
be paused. In this mode, to activate QuickView when viewing different files,  
manually toggle the feature.   
 
Quickview single file mode allows you to have each of multiple MagicView 
sessions linked to a different ecco file.  ( Activation from within the desired 
MagicView session by pressing Winkey + Shift + Q insures you are linking the 
desired session with the active file. )   
 
Note: An alternative multi-session setup that works well also, is to have an 
'internal' sidebar session in QuickView mode,  and a secondary external 
session in manual mode. 

  

Press Winkey + Alt + Q to toggle QuickView AutoSave.   

(Found also on the File > Folder Options menu) 

Page 45 of 80MagicView



Normally,  MagicView will only save changes you make to a page based upon 
your explicit instruction to do so.  Eg., Control + S,  Shift right click on the left 
navigation button,  or a confirmation to a 'Save This?' dialog.    In AutoSave 
mode, changes are automatically saved when a new view page is loaded.   
The feature is convenient,  but involves some risk-- all and any changes will 
be saved without your confirmation. 
 
NOTE: There is an alternative method for QuickView to interface with ecco.  
For most systems and notepad setups the alternative will work faster than the 
default.  The alternative method does not work on some unique 
system setups, and so is not the initial default.  You can select the alternative 
method via File > Folder Options > Alternate QV connection.   The selection 
take effect the next time QuickView is activated (so if you changes the setting 
while QuickView is activated,  toggle QuickView on and off once to activate). 
 
Please initially test your QuickView connection method with AutoSave turned 
OFF,  so that there will be no risk of data loss.  (Either connection method is a 
good choice depending upon what works best on your system.) 
 
Also Note: if using the 'slang' extension, do NOT close an untitled ecco file 
while QuickView is connected to that file.  Closing untitled (ie. newly created 
and yet unsaved ecco session with no actual file in disk) sessions with the 
slang extension while connected to QuickView can crash your ecco session.  
Just be sure to turn off the QuickView connection before closing any "untitled" 
file. (You can switch files freely, but do not close any untitled file actively 
connected to QuickView.) 

  

  

Select Folders > Options > Phonebook based QV  (or select from the Control + 
F1 configuration menu) to toggle Phonebook based QuickView mode. 

   

Phonebook based QV mode applies the QuickView in the same way the 
Phonebook Form works in the Phonebook tab. The MagicView page 
displayed is for the parent phonebook item (or TLI if none).   Unlike normal 
QV mode,  the view page for each parent phonebook item (or TLI) will be 
displayed even if it is empty.   

This option allows using QuickView to maintain a master viewpage for 
each item in the phonebook (or each TLI).  Every sub item can have its 
own viewpage,  but the page will not be accessed automatically when in 
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QV Phonebook mode.  Instead, the 'master' viewpage is displayed. 

QuickView mode does not have to be restarted to toggle the Phonebook 
based QV option. 

  

Note: the 'Phonebook' viewpage can always be loaded manually via 
Winkey + Control + /  . 

  

   

  

  Instant Zoom 

 
Overview:  Instant Zoom allows for the quick zooming and of the MagicView 
pages from any MagicView sate.   Instant Zoom can be used while MagicView 
is in standalone or in 'sidebar' mode.  

  

Press F11 to toggle Instant Zoom. 

  

For zooming the size of a viewpage,  use the "Zoom" slider.    

Clicking on "Zoom" will restore the zoom to 100%. 

  

Alt + Z ,  Alt + Shift + Z,  and Alt + Control + Z  (or Control + minus  and Control 
+ plus) will also zoom out, zoom in,  zoom at 100%,  respectively. 

  

  

  Hotkey viewpage load 

 
1) With the cursor on any ecco item with saved content, press Winkey + Z from within 
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ecco, or Winkey + / from within ecco or MagicView to view.   You can also simply double 
click on any ecco item with an attached MagicView page. 

  
A) Double Clicking is enabled with full install.  (Executing "MagicViewView.exe"  
will also restore proper functionality.) 
  
B) Double Clicking on empty items (ie. items without attached MagicView pages) 
will not invoke MagicView.    
  
C) Because double clicking requires Ecco to process the item you click on,  items 
may update slower,  even much slower than the 'instant' update of Winkey + /  . 
  
D) You can run MagicViewView.exe from scripts/extended rules  to have 
MagicView open the currently selected item's page. 
  
  

  

2) You can also press Winkey + Alt + /  from within ecco to view the saved 
content of the active ecco item directly in your default browser.  
  
  
 
3) From ecco or from within MagicView, Winkey + < and Winkey + > will move to the 
next/previous item in your .eco file and display the saved content (if any). 

A) Alt + <  and Alt + >  move back and forward between recently viewed 
MagicView pages.  

  

History Menu 

 F5 activates the 'History' menu.   

 You can select one or multiple pages to view.  
 

 Use Alt + L  to pull a page from a multiple page view,  (multiView borders must 
be enabled), to edit any selected item, and then press Alt "<" (or click again on 
the timeline selection panel) to instantly reload the multiple page selection.   
 
This feature is invaluable when working on projects with multiple data pages. 
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Note:  So long as the file is still open in any ecco session, you can view a page from 
the history menu even if that page is in a file other than the currently active ecco file. 
 (You can also view pages from entirely different ecco sessions opened with 
EccoMagic's 'Ecco Multiplexer' tool.)   When selecting multiple pages to view from the 
history menu,  only pages from the same file as the first selected item will be included. 

  

  

  

 
 Multiple clips can be viewed from ecco (or the history menu) at the same time. Just 
select them, and view.  
 

  

 
A) The View - multiView Borders option controls whether the multiView clips are 
defined by individual item. 

  

 
B) multiViews can be printed, exported,  or 'dragged & dropped into Word, 
emails, etc.'  as reports. 

  

 
C) When multiView borders are selected, you can: 

1) Move back and forth between item sections using Alt + PageUp 
and Alt + PageDown. 
  
2) Jump directly to any section using Alt + Home. 
  
3) Edit any individual page by pressing Alt + L, and then Control +L to 
jump back. 
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Viewing Mode  

  

The normal mode for viewing is "Magic" mode.  

 
A) You can add additional clips (pasting, drag&drop, etc.), add links, add graphics 
links, etc. 
 
B) You can also edit, ie. take notes. 
 
C) If you edit a 'combo' clip and save it, you will be replacing the single (or original) 
clip with the full combined multi-clip. 

  

 
An alternative mode is "View" mode. 

A) View mode is useful in two primary ways.  First, the page is displayed 
99.999% exactly like the page would appear in a standard web browser.   
Second, you can press on links directly.    
 
B) To alternate modes you press F2, or click on the 'Mode" button.   
 
C) You can also directly select 'Magic' mode via Alt + M,  and 'View' mode via Alt 
+ I. 
 

  

NOTE: You can activate links even while in 'Magic' mode, by holding down the "Alt" 
key while clicking on the link. 

 
 

NOTE: By default, links are opened in a fresh browser window. It is highly 
recommended to use the MagicView in this way. If, however, you desire to view 
linked pages inside MagicView itself (you can instantly save them), in the View 
Menu there is an option to 'Browse Internally' within MagicView itself.  

 
  
There is a special "Package" mode for editing linked and internalized Word, Excel, and 
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similar files. 

A) Alt + F1  toggles Package Edit Mode.    
 
B) Control + S normally saves externally linked packages.  For internalized 
files the extra step of explicitly saving the page is required.  (Shift out of 
Package mode and press Control + S again,  or,  Click on the 
"FILE"  button and select a save option.)   Remember,  saving an 
internal page does not also save the .eco file unless you expressly 
command it (eg., Winkey + S when not in Package mode). 
 
C) If non-obvious this mode is not available when viewing native MagicView 
pages. 
 

  

  

Indexing / Bookmarking 

  You can instantly create an index of bookmarks for any page: 
 

A) By using the "Index" button (or Alt + X),  you can create new index entries.   

i) Any highlighted text will be the default bookmark name.  If shift is held down 
when "Add Bookmark" is clicked,  the bookmark will be added instantly,  with the 
markre-selected when the bookmark is accessed. 

ii) You can 'instantly' add selected text as a book mark by Right Clicking on the 

Index button (  ) .   Ie. this is the same as left clicking and then selecting 
Add Bookmark.  

iii) Bookmarks are saved with the MagicView page in your ecco file,  and will be 
available whenever that page is accessed, including by other users sharing a 
networked file. 

iv) Adding a ">" prefix to any bookmark name will cause the mark to re-select 
the text selected at the time of marking, as opposed to just moving to the mark 
location.  (The ">" is not included in the bookmark name). 

  

B) To jump to any bookmark,  just click on the bookmark in the indexlist. 
 
C) To search for a bookmark hold down the control key when activating the indexlist. 

Index
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 "Regular Expressions" are allowed for complex searches. 
 

 For simple searches,  begin the search criteria with "*".  (For example, 
"*this") 
 

 You search also based on the size of the bookmark name: 
 

 "< X" for bookmark names shorter than X characters,  (Ex. "<4"). 
 "> X" for bookmarks longer than X characters, (Ex. ">4"). 

 
D) To delete any bookmark,  hold the control key down and select that bookmark from 
the indexlist. 
 
E) To add a hyperlink to any bookmark,  select any text and invoke the index list (Alt + 
X).   Hold down the shift key and select any bookmark to add a hyperlink.   You can 
insert a table of contents to all bookmarks in a viewpage by holding down Shift and 
Control when Selecting "Add Bookmark" from the Index menu.  

 
  

  

EM Favorites 

 
Helpful when working with multiView, or page history,  Alt + Shift + Control + V  will 
mark all items currently displayed in  MagicView as EM Favorites,  and open the EM 
Favorites view in ecco. 

A) Alt + Shift + V  toggles the EM Favorites folder setting in ecco for all 
items in the active MagicView display. 

  

B) You can also directly remove items from the EM Favorites folder in ecco 
manually, as you would any other folder. 

  

C) For example,  try Alt + Shift + Control + V for any item's page, and see the 
EM Favorites view open.   Any item's page can be added or removed from the 
view from within MagicView by using Alt + Shift + V. 

  

Page 52 of 80MagicView



  

  

 Viewing options 

  

The "View" menu allows selection of many different viewing options, including: 

  

1.  Attaching MagicView as an Ecco sidebar or viewpane.  

 
MagicView can be used as an external window, a sidebar to Ecco, or as a 
view pane inside Ecco. 
 

 To toggle Ecco attachment mode,  press Winkey + Control + Z from within 
Ecco or MagicView.  ( View > As Sidebar  from the MagicView option menus). 
 

 To toggle between sidebar and viewpane modes when attached to Ecco,  use 
the "Internalize" option in the View menu (Winkey + Alt + Z).   The internalize 
option is only relevant when MagicView is attached to Ecco (View > As 
Sidebar) and determines if MagicView is attached as a sidebar or as an 
internalized viewpane within Ecco.  (This can also be selected per each 
viewtab individually (Control + Shift + F6),  so that for selected tabs MagicView 
is a sidebar,  and for others, an internal viewpane.) 
 
  When attached as an internaized viewpane the following applies: 

 
 
In a single view Ecco notepad, the MagicView sidebar is added over the 
right side of the notepad.  Normally the MagicView pane is set at 50%.   
To reduce the pane size to 1/3,  select the View > MagicView Position > 
Smaller Frame option. 

 
 
In a double view notepads, the sidebar is added over the right side of the 
notepad.  You can manually control the size of the MagicView pane by 
resizing the notepad's left side. 
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In triple view notepads,  the sidebar is added over the lower right corner 
view of the notepad,  and by manually setting the size of that pane,  you 
can exactly control the size of the MagicView window. 
 
Winkey + H to minimize MagicView. 
 
F11 to maximize MagicView. 
 
F6 to toggle a smaller MagicView pane size. 
 
Shift + F6 to toggle a larger MagicView pane size.  
 
Alt + F6 to toggle the default MagicView pane location from right to:   

 left when the pane is 'internalized' 
 bottom when the pane is external 

Alt + Shift + F6 to toggle top or bottom pane placement (both in multi-pane 
views and vertical pane mode). 

Winkey + F6 to toggle vertical pane mode (for single and two pane ecco 
viewpads). 

Control + F6 to exclude the current notepad for MagicView 'internal' mode. 
 
Control + Shift + F6 to edit the view exclusion list.  "Calendar" = 1, 
"PhoneBook" = 2, etc.  Use the same numbers as used for Alt + Number 
view change shortcut in Ecco.  Enter a list of numbers, eg., "5,6,8". 

   
 
 
NOTE: When attched to Ecco, the MagicVew "Compact","Standard", and 
"Broad" sizing do not apply to the MagicView pane size.  Those options 
apply to MagicView when viewed as an external, stand-alone window.   
The "Smaller Frame", "Larger Frame", "Left Frame", and "Top Frame" 
options control sizing when MagicView is attached to Ecco as an internal 
viewing pane.  (View > MagicView Position).    "Maximize" (F11) and 
"Minimize" (Winkey + H)  apply in all view modes. 
 
 
 

 To move an attached MagicView pane from one Ecco instance to another,   
press Winkey + Control + Z  from the Ecco instance you desire to move the 
pane to.  (Using MagicView with multiple Ecco instances requires first applying 
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the freeware EM patch to ecco32.exe available at the www.EccoTools.com 
board.) 

  

 
MagicView will always start as an independant window if another 
MagicView session is already attached to ecco. Each different session 
of MagicView will apply its own settings.  Be sure to properly setup 
multiple MV sessions if attached to the same Ecco instance. (For 
example one MV session on top, another set as bottom,  and each Ecco 
view setup with at least two additional views for placing the MV sessions).  
 

  

  

 Advanced control 'tricks': 
 
        Note: When resizing panes in Ecco, you'll see the cursor  change to a 
black double arrow with a vertical or horizontal bar in the middle.  That is when 
you can click to drag & resize panes.  If you see a double white arrow,  or 
arrows without the vertical or horizontal bar in the middle-- that is not exactly 
the right location,  move a little bit to find the 'spot'. 
 
 

 Making a "MagicView" Tab.  This 'trick' allows you to turn a notepad tab 
into a MagicView tab.  Steps: 
 
 

 Add a Tab to ecco  (View > Notepads > New Notepad).   
 

 Then add another.  It doesn't matter what folders,  best to use fresh, 
'empty' ones. 
 

 'Grab' the border between the two views and resize them so that you 
entirely close the right view by moving the bar all the way to the right. 
 

 For advanced users,  a side by side calendar that does not have a 
tab (Ecco's File > Properties > Display) will act as a MagicView pane 
if accessed via Alt + 1. 
 
 

 Two views and External "MagicView".  This allows you to setup specific 
tabs to have two notepads and no MagicView. 
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 Add a third notepad to your two view notepad. 

 
 Drag the third window almost all the way closed.   But leave a tiny bit 

of 'edge'. 
 

 With a little play you'll understand the idea here.  A very small,  even 
so small you can't see it but it's still there, 3rd pane will force 
MagicView to external mode. 
 

 Note: if you close the 3rd pane by right clicking on its folder tab,  
you've created a manually adjustable single pane + MagicView 
view.   You can control the exact width by adjusting the vertical 
dividing bar. 
 

 You can 'grab' the horizontal adjustment bar even if you can't really 
see it.   If you 'close' the 3rd pane,  you can 'reopen' by dragging up 
the bar-- from the very bottom. 
 
 

 Single view and External MV.  
 
 

 Create a two view external MV notepad,  and adjust the second pane 
so that it is nearly invisible.  You'll need to leave a tiny bit more than 
with the 3rd pane,  enough to see a sliver of the edge of the pane's 
original scroller bar on the right side. 
 

 A little play with this will make perfect. 
 
 

 Calendar/Phonebook to Right of MV. 
 
 

 Juse the View > MagicView Position > Left Frame option. 

  

  

2.  Keeping stand alone MagicView shown always on top.     
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Toggle "Always on Top" from the View menu,   or use the Winkey + S shortcut. 

 
  

3.  Instant MagicView Sizing when used as 'stand-alone' window.     

 
Winkey + M  for Compact 

Winkey + Control + M for Midsized 

Winkey + Shift + M for Larger 

F11 for Full screen 

Winkey + H for minimized 

  

  

Play freely with any of the viewing options above or that you'll find in the "View" 
menu.  
 

NOTES:  
 
        1. Very much recommended not to generally use the "Browse Internally" mode. This 
mode is not relating to the type of MagicView pane,  but instead,  how links are handled 
when clicked.  While MagicView can technically 'browse' (when clicking on a link in 'View' 
mode,  the linked page is downloaded and can be displayed in MagicView or in a normal 
browser window)  MagicView is not a browser, and not designed to be a browser per-se, 
 and uses only the default protection settings (ie. often NONE depending on your systems' 
setup) against 'cookies', pop-ups and the like.    
 
 
        2. The View > Restrict Hotkeys  (or pressing the Pause key) option will 
restrict magicview hotkeys to those issued from within magicview,  (or from 
within Ecco if the magicview pane is a sidebar).  If activated, the universal right 
click feature will function normally.  A small marker shows up to the bottom right 
of "Item Text:" when this mode is activated (the magicview tray icon will also 
reflect the restricted status).  The primary purpose for this option is to allow 
safely using multiple magicviews in different ecco sessions.  By restricting 
hotkeys in the inactive sessions,  you can be sure exactly where hotkey clips are 
saved.   If you want to access an ecco session from an 

Page 57 of 80MagicView



external magicview  while there is another magicview as a sidebar,  you can use 
the universial right click feature, or, standard Alt + functions,  or, if desired you 
can completely restrict the sidebar's hotkeys with View > (Shift + ) About. By 
holding down the shift key when selecting "About" from the View menu,  all  
hotkey functions will be frozen until you press "OK" to close the restriction box. 
 
 
 
        3. There are some known issues regarding integration with the calendar 
view in relationship to changing the stucture of the view while magicview is 
internalized.   If you experience magicview 'flickering' in the calendar view when 
you add additional views to it,  just click to another viewpad and back to the 
calendar view.    
 
 

  

  

  Saving Graphics, formating, etc. 

 
 
GRAPHICS 

Graphics can take up a *HUGE* amount of space, and although the option for 
saving graphics along with your web clips is integrated into MagicView, the 
core purpose of the program is information gathering and management.  
 
Images and attachments are normally saved in a special ".web" folder in the 
same directory as your ".eco" (or ".ecc") file.   The folder has the same name 
as the ecco file,  with the extension ".web".    You can 'zip' the directory to 
transfer or share attachments.  Clips with saved attachments will work without 
the .web folder,  but you won't see the attached images. 

To stop an image while it is downloading, or to cancel the download of an 
image (including in cases where an image's download gets 'stuck'), press 
Control + Alt + F1. 
 
All of the text from saved clips is stored within your .eco file unless you specify 
otherwise.  MagicView will compress and often clean up some of the 'html 
code' of saved pages.  If you want to archive web pages for "evidence", it is 
best to have a directory dedicated for that purpose. Just use your browser's 
built-in save complete web page feature. To add the saved page to ecco (so 
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you can find it later), view (in your browser) the page you have saved to disk, 
and clip part (or all) of the content to ecco. So long as the directory you saved 
the webpage to exists in the same location, or you "Ground" the MagicView 
pages, they will always show the graphics, etc. when viewed.  

MHT formatted clips generally retain formatting and script actions better than 
normal MV page clips.  However,  MHT clips do not have the functionality of 
standard magicview clips. (Some functionality, such as integrated outlining 
(selecting text and 'copy to child' is retained in MHT clips).  You can convert a 
MHT clip to a normal MV clip by viewing the MHT clip in a browser window (Alt 
+ W), selecting all (from the browser) and clipping to a new MV item, and 
'grounding'.    (Note that MV clips will typically save more of the 'hidden' images 
than saving in MHT format clip.)   

While the MHT clip option may seem attractive to the 'perfectionist' within us,  
MV clips are much more functional.   If our purpose is information gathering,  
MV clips are designed for that.   If our purpose is saving a 'memorial' of 
websites past,  MHT is there.  In extensive studies involving MV,  it turns out 
that those who save large quantities of MHT format clips never, or seldom, 
actually go back to look at or use them.   MagicView will serve you best as an 
information gathering & organizing tool if you keep your purpose in focus.   Clip 
those key parts which contain the information (text or graphical) that can benefit 
you,  and let the 'fancy' formatting go.      
 
MagicView allows clipping screen shots either into MagicView pages, or directly 
into Ecco as sub-items. 

You can freely copy and paste graphics images within and between MagicView 
pages.  Simply mark the area to copy,  Control + C copy,  and then Control + V 
to paste where desired.   To copy an image as a 'hard' image that you can 
paste in any program that allows pasting of graphics,   control + right click on 
the image, and select "Copy" from the dropdown menu. 

  
  

Note:   

1. The features of EM Screen2Ecco for pasting screen clips into ecco are 
built-in to MagicView.  Press Winkey + Shift + F12 to activate. 
 
2. When clipping from a disk archive of a web page,  to see the graphics, 
etc. from Ecco,  unless the page is "Grounded", the directory folder of the 
archive must be in exactly the same location when the page is 
viewed.   (Note: Unlike when clipping from a disk archive, when pages 
have been "Grounded", MagicView's automatically maintained add-on 
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attachment directory can be anywhere, so long as the ecco file is there 
as well.) 
 
3. To compress the files in the attachment directory and remove any old 
attachments that are no longer linked to any item's MagicView page,  use 
the File > Folder Options > Compress Attachments Folder tool. 

a. Depending on machine speed and the size of the file,  
reconciliation can take some time.   (A completion message 
pop-us when done.) 

b. This tool is best use only occasionally.  The file where the 
active MagicView page is located is reconciled. There is 
usually no benefit internally to the ecco file (although any page 
fragments will be removed). Each individual file needs to 
reconciled separately. 
 

c. For 'advanced' user's who have setup their disk structure to 
allow sharing viewpages between ecco files,  it is important to 
remember to use the special compression for shared .web 
folders.  (File > Folder Options > Cross-File Shared Folders > 
Compress Shared.web folder for active Ecco file for every file 
sharing the folder (be sure you've used option with all of the 
sharing .eco files!) and then  File > Folder Options > Cross-File 
Shared Folders > FINALIZE compression of shared .web 
folders ). Remember too, it is not necessary to *ever* 
compress the attachments folder-- it just saves disk space (and 
in theory clears memory and space in the .eco file caused by 
error conditions or system failures, etc., if any). 

 
  

4. MagicView will normally try very hard to download all graphic images.  
Sometimes the server or connection is slow,  so be patient.  In the rare 
circumstance that MagicView becomes 'locked' in attempting to ground 
an image (and does not respond even after 20 - 30 seconds),  you can 
'reboot' MagicView by opening a new MagicView session and holding 
down the ALT key when you press "OK" on the opening  MagicView 
window.  The Advanced Folder Option (Control + F1) "Fast unverified 
image grounding" will ground images much faster, but doesn't verify 
images are actually downloaded nor try very hard to 'grab' files from 
difficult servers.  For most uses, 'Faster unverified image grounding' is 
the best option. 
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5. Via the configuration menu (View > Configuration  or Control + F1)  you 
can select under "Advanced Folder Options" to use "Fast unverified 
image grounding".   If you use this option note:  
  

A) Unlike verified grounding, in the case of a problem in 
downloading, missing images will show on the page as missing 
whereas verified grounding retains the original image reference if the 
image cannot be grounded. 
  
B) On some systems, it will be normal when using unverified 
grounding for the images to 'vanish' before your eyes from the 
viewpage.  When the page has finished grounding  you can reload 
the viewpage (Control + L) to restore the view, if necessary. 
  
C) If images still seem to be missing after grounding, your can be 
sure if you test the viewpage in your default browser (Alt + W).  (For 
example, some images may have been properly grounded but 
require 'View mode' as opposed to 'Magic mode', to view, etc.  
Viewing a page in your browser is a quick way to test any page that
appears to have an issue.) 
  
D) If you have a firewall you will likely need to authorize internet 
access for "MVHelper" to use unverified grounding.  

  
6. You can easily insert links to graphics images in your MagicNotes by 
dragging & dropping any graphics file.    

A) If you want to include the image in the file's .web directory,  either: 

i) Copy to file to that directory first, and then drag & drop into 
MagicView;  or 
  
ii) If the "Ground local files" option is set,  Ground the page after 
the images have been added,  and the images will be 
automatically copied to the file's ".web" directory.  ( NOTE: 
Grounding does not copy local files to the .web directory unless 
the File > Folder Options > Ground local files option is 
selected. ) 
  

B) If text is selected at the time you drop an image into MagicView,  
the image will be inserted immediately prior to the selected text.  
Otherwise, images are inserted at the beginning of the MagicView 
page. 
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C) If you drag a image to the MagicView button sidebar and hold 
down 'Shift' while releasing,  you will be prompted for advanced 
photo options.   You can also modify these options by pressing Alt + 
P when any image is selected. 
  
D) You can resize images by dragging the edge 'dots' which appear 
when an image is selected. 
 
E) By right clicking on any image, you can instantly shrink the image 
to 'thumbnail' size,  restore the full size of the image, or view the 
image in the standard image viewer.  

 
  

 
FORMATING 

Many modern web pages use special "style sheets" known as CSS, to save 
the formatting information for the displayed pages. So long as you can access 
the original site, and so long as the formatting file is available, you will 
normally see the original formatting in your clip views. However, if you want to 
make sure that you will always see the original formatting, you can "Localize" 
the CSS. Simply: 
 
  

A) Select the "Localize CSS" command from the edit menu,  
 
B) Copy a clip into MagicView using shift+Control+V,   
  
C) Copy a clip from a browser using Winkey + Alt + C, or 
 
D) Use the "Ground" function. 

 
  

NOTE: The CSS style information can be larger, sometimes 2-3 times larger, than 
the actual text you are gathering. In most cases its not necessary to save the CSS 
style info of a web clip.  
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  Private Notes  

 
Private notes can be added to any view page via Control + F8  or the Format > 
Advanced Formatting menu.  This feature allows you to add notes and even 
graphics to any view page while at the same time retaining the option to instantly 
view or print that page in its original state. 

F8 toggles display of the notes. 

Shift + F8 toggles display of the note markers. 
 

  
Note: 
  

1. Moving or deleting any collapsed note asterick pair will move or 
delete the collapsed note.  
 

2. Hiding private notes does not remove them from the view page.  If 
other users have acces to the viewpage they can toggle display, 
and,  exported pages include a copy of hidden notes in the export.    
 

3. Deletion of collapsed note maker pairs will entirely delete private 
note. 
 

  

  Searching within Ecco 

        

 To search for text within MagicView pages,  within Ecco search "entire File" and 
search "all columns".  To search for text within the 'tag lines' search only "Text". 
 
        One trick is to use filters as part of your search.   You can create a filter for 
items with some value in the "MagicView?" folder to limit searches exclusively to 
MagicView pages.  You can also use any category tags (folders) as filter/search 
criteria to search for and/or select all the pages tagged with specific folder(s) tags. 
 
        You can select tens, even hundreds of MagicView page items,  and view them 
as a single MagicView page.  (May take a few moments to load a large number of 
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pages,  or multiple pages that are extremely long-- be patient).   You can then, for 
example,  drag and drop your results MagicView page directly into Word, etc.  

 
  

  

  Recording Audio Notes 

        

MagicView's  Audio Note Recorder is designed for making quick audio notes.   

  

Control + F10 instantly starts a new recording. 

Shift + F10 pauses. 

Control + Shift + F10 finalizes and converts the recording to a MV page. 

F10 activates the Audio Note Recorder menu.  

PLAY plays from the beginning of the Audio note unless clicked while the 
recording is paused. 

        You can click on  <<   to Rewind  [ or press  Control + Alt + F
10 ]  and  >>   to Fast Forward  [ Shift + Alt + F10 ] . 

RECORD inserts new audio from the active audio position. (Record mode 
can be entered directly from Play mode) 

CLEAR empties the active recording. 

FINALIZE converts the recording to a MagicView page. 

Winkey + F10  can be used to edit and replace an existing Audio Note in the 
active viewpage. 

Note: If the new recording is then finalized, the original 
Audio Note will be replaced by the newly edited Note.  
Keep in mind when replacing existing Audio Notes that 
while the old note is removed when you 'Finalize", the 
fresh Note is not saved until you explicitly save it.
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(Audio Note Recording is also accessible via the main Edit > Recording menu). 

Settings for volume,  selection of audio source, etc.,  are controlled via the 
Windows audio control. 

  

  

  Other cool stuff.... 

 
Control + Left Clicking in "Viewer" mode allows access to an alternate 'browsing 
style' context menu. 

Control + F11 toggles between Ecco and MagicView.  

  

Format & Outline Controls  

Alt + T is the shortcut for the Format menu.   

"Label Value" can be used to control outilne numbering/lettering as well as 
bullet type. 

  "S" or "Square"  

 "C" or "Circle" 

 "D" or "Disk"  

"Label Type"  (or Alt + Shift + N) can be used to control the type of outline 
numbering (A,a,1,I, and i). 

Alt + a is the shortcut for the Advanced Format menu. 
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Color Control Controls  

Shift + Click on the "Highlight" button will highlight an entire paragraph.   

Shift + Click on the "Color" button will likewise apply  text color to an entire 
paragraph.   

Click on the ">>" box next to "Highlight" or "Color" to set the highlighter or 
fontcolors. 

Shift + Control + Click  on "Highlight" or "Color" buttons will remove any 
paragraph wide background or font color setting. 

Control + Click on "Highlight" to remove text highlighting.  (Alt + Space 
removes background and font color on other text selections.  Setting the text 
color to black removes font color.) 
 
Control + Click on color well next to the Highlight and Color buttons, will toggle 
'Color Well' mode, making the active color selection large & bright.   (Option is 
provided for those who find it helpful,  normally off by default to avoid the 
distraction of bright colors in the command panel.) 

Right Click on the color well next to Highlight will clear the selection's 
background color,  (shift + right click to clear paragraph background color). 

Right Clock on the color well next to Text will clone the selection's colors (shift 
+ right click to clone paragraph colors). 
 

 
Note: 
 
        Paragraph or 'box' highlighting can be incredibly helpful 
for highlighting and offsetting information in a clip.   
 
        For web pages that don't use paragraphs (even thought 
visually it may look like they do), create your own  paragraph 
by simply pressing Alt + Control + P at the desired paragraph 
start.   You can do the same by pressing the "Enter" key 
where you want the highlight box to appear, then mark the 
text you want included and drag it to where you created the 
new line with the "Enter".  
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        Use Shift + Enter to enter 'soft' returns (ie. vs Enter to 
start a new item/paragraph). 
 

  

Columns and Tables  

Control + F9 will create new columns or a table.   

F9 will toggle display of column or table borders.  

  

Function Access Structure   

As in ecco, most commands can be launched in multiple ways.  In addition to 
the command's hotkey,  most commands can be triggered via the main function 
menus and the menus' Alt key shortcuts.  

Many features which are typical to other Windows programs (such as MS 
Word), may not have been specifically listed in this documentation.  Please see 
the menus for a full listing of features.  For example, you can 'Find & 
Replace' (Control + F or Edit > Find & Repalce)  text in your pages and clips, 
and  'Find Next" (F3)  ,  etc. Hopefully, use of those basic functions should be 
self-explanatory.   

Hopefully, also, most 'hidden' features are mentioned  (Such as the Control + 
F3 'instant search for selected text' feature,  Shift + F3 to continue searching 
backwards,  or options such as holding down the shift key when pressing 
'Enter' or clicking "Find" in the Search & Replace dialog to search backwards, 
and holding down the control key in order to suppress the "Text Not Found, 
Search from Beginning/End of Page ?" prompt).  

Normally you will not be able to activate links to local files and programs on 
your own computer unless you send the viewpage page to a browser, or use 
Alt + Click.   The idea behind requiring this additional step is to protect against 
clips containing 'dangerous' links or scripts trying to activate programs on your 
machine. Alt + Click will allow you to activate links even while in 'Magic' mode. 
In 'Magic' mode may need to Alt + double click to activate links on some 
viewpages. You can also right click on a link and select "Jump to Link". 
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Misc. 'usage' notes and tips: 
 

 
Have taken to the practice of sending misc. requested info to friends & family directly 
from my organized ecco clips.  Just select the relevant ecco outline sections,  press 
Winkey + / to load the 'combo view'  and then drag & drop the indexed clip into an 
email.  
 
The only problem with this so far is that I keep getting asked to let them know from 
whom I forwarded the mail.   For some reason the info in this format looks like a report 
someone else wrote up and I was just forwarding on...  go figure. 
 

  

 
MagicView is an Ecco 'Add-On'-- if you have problems using MagicView, try it with 
ECCO running!  (Although Ecco's window does not need to be open).   
 

  

 
If you have upgraded to a registered version of MagicView please examine your 
default settings (Control + F1).   The upgrade version attempts to correctly apply 
settings from any previous install,  but is not always successful. 
 

  

 
Block Calc will calculate ACROSS each line in the block, and then add the totals 
together.    
 
All basic math functions work, as do parens.  Math functions include: 
 
        *        'Times'        /         'Divided by' 
 
        +        'Plus'          -        'Minus'  
 
        ^        'Power of' 
 
and for programming types: 
 
        Base16 (0xFF)  freely interchangable with Base10 
 
        ( Include "#HEX#" in block for Hex result ) 
 
        << and >>        Bit Shifting 
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        &, !|, and |        And, Nor, and Or 
 
  

 
Via the File menu,  holding down the shift while clicking on "Print" (or pressing "n") will 
open a HTML print preview pane. (System memory settings may prevent huge multi-
page viewpages from displaying in the preview pane.) 
 
When printing ( Control + P  or File > Print ), enable "Print background colors and 
images" to include highlighting in printout.   
 
Printing to PDF printer drivers works great from Magicview.  ("doPDF" is one 
recommended example of a free PDF print driver allowing magicview printing direct to 
PDF format).   
 

  

 
MagicView is designed to clip from a variety of sources, including web pages from the 
internet.   MagicView will have a hard time initializing or clipping pages if the program's 
internet access is blocked by firewall programs such as ZoneAlarm. 
 

  

 
Try out the F5 'magic history' tool.   Note that you can either double click on a single 
item, -or-, you can select multiple items (shift or control click), and then click on the 
'click to open' link at top of history box to open multiple pages at the same time. 
 
(Be sure to move the history box out of the way to see MagicView) 
 

  

 
Sometimes web pages will use 'fancy' quotes or other unusual Glyphs.  Unless such 
pages properly identify codepage, MagicView accepts the text literally (because 
sometimes the aberrant glyphs are intentional, or part of an improperly identified 
unicode page). In such a case, you'll see something like this-- "under a ג€� parent.ג€�  
".   Instant fix via File > Strip > Aberrant Glyphs (or Winkey + Alt + A).  Fixes example 
text to "under a “parent.”  ", etc. 
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Margins, line spacing, etc., can be set by a number of pixels (eg. "7"),  by a percentage 
(eg., "10%"  margins or "130%" line height),  or by point size (eg., "18pt", ".1in", etc.). 
 
Alt + \  toggles single and double spacing. 
 
 
Alt + ]  allows setting precise margins.  
 
        By preceding the margin size with "<" or ">"  the individual margin size of the left 
or right margin can be individually selected. 
 
        By preceding the margin size with "v" the verticle spacing can be selected. 
 
Alt + Shift + ] allows setting precise verticle spacing. 
 
        Preceding the padding value with ">" will apply the same value to both padding 
and margins. 
 
 
These options are found on the "Format > Advanced Formatting" menu ( or Alt + A ) .   
 
  

 
Dragging image files (from the local hard disk or the net) will insert the image at the 
cursor.  (Note: images are not copied to the .web folder unless you explicitly ground 
the viewpage after dragging & dropping the images.) 
 
Alt + P allows editing the Images' properties. 
 
Dragging HTML or TXT files will append the html or text to the active MagicView page. 
 
Dragging any other file will create a link to the file for the marked text.  If no text is 
marked,  a link will be created at the bottom of the page, with the link's file name as the 
linked text.  
 
  

 
 

 
Exporting to MHT ( File > Export as MHT ) should work fantastically on most systems,  
and should work better than Explorer's "save as MHT" even on problematic 
setups.   Note: 
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                -  With 'grounded' viewpages (Alt + G, 'with images' clips, etc.) the most 
graphic images will be saved.  
 
                -  Most images are exported and saved even for non-grounded files.    
 
                -  Some system setups with older windows DLL files can cause some issues 
with the MHT export.   
 
                -  Test exported files on another system before you rely on them. 
 
 
You can also export to MS Outlook compliant "EML" format. (If outlook/outlook express 
is installed on your system,  you can access .eml files simply by double clicking on 
them.)    
 
On most systems,  you can email viewpages (including graphics & layout) directly from 
MagicView.  Simply hold down the shift key when pressing the "Save" button when 
exporting and the viewpage will be exported as an EML file and the email send dialog 
will be activated.  Then, simply click on "Forward" to send. 
 
  

 
 

 
MagicView can store up to 8 megs of data per viewpage per ecco item ,  and a virtually 
unlimited amount of data per viewpage per ecco item if the data location is set for disk 
storage.   
 
You can drag literally hundreds of HTM, HTA, HTML and TXT files into a magicview 
page (drag to Item Text box and hold down shift key) and combine into a single 
magicview page. 
 
This help file is over 250,000 bytes in size,  and hopefully works smoothly on your 
system.    HUGE viewpages of 2, 8, or 10+ megs will work fine,  but on most systems 
some functions will respond *very* slowly.   Please be patient.   Even basic functions 
such as Alt-X (index)  Winkey-P (page encryption),  and others,   may respond very, 
very slowly  on multi-megabyte single viewpages.    
 
Also note that on huge, or even large pageview items stored in ecco,  you may see 
ecco 'flicker' when the item is opened, or saved.  This is normal,  as is the slight 'lag' in 
loading and saving huge viewpages inside of ecco. 
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MagicView has a 'not officially supported' function for most Windows 7, Vista and some 
XP systems.  On compatible systems you can vocalize any viewpage selection by 
pressing Winkey + Shift + 7.   
 

  

 
To move & gather items with viewpages very much recommended to use the 
EccoMagic Hijack!, Hoist, Move, & Gather tool available here.   You can also cut items 
in Ecco (Ctrl + X),  and then paste them at the desired location (Ctrl + V).   To attach 
viewpages to items in other files,  simply select the desired item,  and select File > 
Save > at Active  (or right click on the left navagation button). 
 

  

  

 
MagicView's tray icon includes a 'Universal Right Click'  option for those who are 
mouse oriented.   When selected, the right mouse button activates the Winkey + F12  
Clip menu.   By pressing and releasing the right mouse button a second time, the 
original 'right click menu' of the relevant application will be activated.  To turn off the 
'Universal Right Click'  right click twice on the tray icon and deselect, or,   hold down 
the 'Escape' key and right click in any application. 
 
Additional options found by right clicking on the MagicView tray icon include 'Next 
Right Click' for a 'single use' universal right click, 'Capture Screen Clip',  and 'Save 
Ecco & MagicView '  which saves both the current MV page and the .eco file.  
 
  

 
Most options can be set directly via the Control + F1 configuration menu. 
 
"Expert Settings"  effect internal ecco data structure and should be used *only* by 
advanced experts.    
 
"Storage Override" should only be used if you understand exactly what that does and 
desire that result.   Normally,  default storage for view pages is inside of ecco,  and 
pages can be designated for disk storage on a page-by-page basis.   Setting override 
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to either disk or ecco will force all pages to be stored at that location-- even if manually 
designated otherwise.   To change the default  data storage location use an 
appropriate default page template and not the 'override' option. 
 
If you upgrade your version of MagicView,  be sure to re-check your configuration 
settings.  Upgrading can cause some confusion with the default settings. 
 
If there is any option or MagicView feature you are unsure of,  feel free to ask here. 
 

  

  

  

 
When getting started with MagicView keep in mind: 
 

 
   

 
MagicView is carefully designed to work with critical data.  Data is only 
overwritten if you do so very intentionally.  The start-up defaults will not 
automatically save changes to view pages unless you issue the command to 
save.   
 
Also,  if your ecco file is not set up to auto-save,  MagicView will not save your 
ecco file (including the MagicView in ecco pages) unless you issue the command 
to do so.   
 
The purpose of this initial setup is to protect your ecco file so that it cannot be 
accidentally changed or permanently modified.  (Control + S  saves the current 
viewpage,   Winkey + S saves viewpage and ecco file together.   If you open 
another viewpage you will be prompted to save changes in the previous,  unless 
the save without prompting option is activated.) 
 
  

 
MagicView's default set-up is to 'thumbtack' page views.  That is,  the page view 
will not update when you change focus of the ecco outline item,  unless you 
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expressly update (for example Winkey + ?).   To activate the quickview mode,   
you can press Winkey + Q. 
 
  

 
MagicView pages are integrated into ecco's outlining functions.   So, for example, 
you are generally much better off marking all the text of a Word file and clipping 
into a viewpage than just attaching a word document as a page   
 
If you want to to keep word specific formatting such as page footers, etc. you'll 
need to stick with attaching the document (dragging the .doc file into the Item 
Text box),  and if desired,  then pressing Alt+G to 'ground' the file-- include it 
within the file's .web folder (instead of working with the file from where ever it was 
dragged, which also works). 
 
  

 
MagicView provides control over specifically how, what, and where selections 
can be clipped.   The array of options can seem overwhelming at first.   It 
becomes much more clear once the basic concepts are understood.  
 
> FIRST ASPECT -- WHERE TO CLIP TO < 
 
MagicView can accept clips which: 
 
        (1) Replace the existing viewpage's content,  
 
        (2) Append to the existing viewpage  or  
 
        (3) Create an entirely new viewpage  (either at the current ecco item 
selection or into a special webclip folder).   
 
 
> SECOND ASPECT -- WHAT TO CLIP < 
 
MagicView can clip based on:  
 
        (A) clipping the selection which is currently marked,  
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        (B) clipping the marked selection as the clip title and clipping the entire 
webpage where the marked text is found,  or 
 
        (C) clipping the webpage found at the address in the currently selected text. 
 
 
> THIRD ASPECT -- TO SAVE COPIES OF GRAPHICS OR NOT < 
 
Additionally you can clip:  
 
        (i) without making local copies of clipped graphics or  
 
        (ii) with saved copies of any graphics in the clipped page/selection.    
 
 
 
Becoming familiar with these three aspects and distinct options will significantly 
clarify the clipping menu (Winkey + F12  or Universal Right Click [activated from 
right click on MagicView tray icon]). 
 
There are also some specialty 'ecco text' clips providing additional powers,  the 
ability to clip from the screen to MagicView or to Ecco directly,  and the ability to 
'capture' a webpage clip in order to 'manually' paste it into ecco.   If you have a 
grasp of the three aspects above,  and walk through the clip menu,   you will 
quickly master it. 
 
 
 
 
(* THE FOURTH DIMENSION -- PHYSICAL STORAGE OPTIONS *) 
 
Clips (and parts of them) can be stored either inside of the .eco file, or in an 
external .web folder stored in the same location as the .eco file:  
 
        (i) Clips including graphics can be stored internally inside Ecco as "MHT" 
format.  One big downside with "MHT format clips is the loss of most MV editing 
capabilities.  
 
        (ii) Modestly sized files, PDFs, graphics, "MHT" format clips, 
etc., work seamlessly when stored internally in Ecco,  and automatically update 
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with synced ecco's (although they do use up extra memory space and 
pointers).  As the size of internally stored files gets larger,  loading time 
significantly increases.  Large (even huge) files, graphics, etc., work seamlessly 
from the .web folder and can be synced with other users on the network via 
network folder sync tools.  
 
        (iii) For most users storing pages, graphics and files (such as PDF, MHT, 
DjVu, EML, ZIP, etc.) in the .web folder is the best option.  Pages and files can 
thus be globally searched by desktop search programs,  and the .eco file size is 
kept very small.   However, if you want to search for content inside of Ecco,  
storing pages (although not graphics, and files) inside of ecco is necessary).  
 
        (iv) Viewpages stored externally can be seamlessly and securely 
encrypted.  Externally stored graphics, files, MHT pages, etc., can be encrypted 
by encrypting the files using Windows file encryption or by encrypting the 
entire .web directory.   All internally stored material (view page text, MHT format, 
graphics, etc.,) can be very securely encrypted inside of the .eco file  (but viewing 
the stored materials is not particularly secure and can be 'spied on' if there is 
active spyware software grabbing screen shots, tracking disk sector changes, 
etc.). 
 
 

 
  

  

And, for 'programming types': 
 

You can use the Control + R command to instantly move back and forth between 
the clip text and the raw HTML and incorporate directly any HTML formatting you 
desire-- including javascript. Some tiny level of HTML compatibility cleanup is 
controlled by MagicView.  (If you want true 100% control,  use an html editor.) 
 
You can use your own page default HTML should you desire.  Simple save the 
html template with the file name "EM_DefaultView.html" in the MagicView 
program directory.  Remember the template gets added to every default note,  so 
best to keep size compact. 
 
You can also set the background color or image for any individual page.  By 
entering "http://...." when prompted for a file name,  you can use a file from the 
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web.   If you want the background saved,  be sure to Ground the page if using an 
image from the web,  or,  use an image from the .web directory.  (Copy the image 
to the file's .web  and select that image as the background image).  [if the .web 
directory doesn't exist for your file,  just ground any clip with web images, and the 
directory will be created.   Or just manually create the directory,  same as the 
ecco file's name,  with the .web extension]. 
 
Advanced, control of MagicView's use of ecco folders is also available (although 
not recommended except where no file will have more than 10,000 Magic View 
pages, in which case the 'Manual Folders' option will give a speed improvement 
for slower systems).   

1) The Alternate Folders option allow a second set of web clips for items. 
 You can manually select to force the alternative folder set,  or to make that 
the default for any file.  You can also de-selected the alternative folder set, 
(useful when there are 20,000 - 30,000 clips in a file, and thousands of older 
clips are then removed).  

 
2) The Strict page choice option restricts MagicView's choice of folders to 
the selected default-- even if it is empty and there is a viewpage  saved in 
the alternative folder.   This is something that normally works automatically, 
 but  additional functionality is exposed for advanced users.  

3) The Manual Folders option can provide some speed improvement for 
slower systems, but should only be used on ecco files with up to 10,000 
MagicView pages. Manual Folders mode will work perfect up to about 50% 
of capacity, about 15,000 pages per file, but will be stuck in manual mode.  

  

 
  

NOTE: You are viewing an extensive, yet pre-final version of the help file.  Please 
look at program menus for more options. 
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© Copr. 2008 - 2009 ISystems. All Rights Reserved. 
Patents Pending.  

EUA, TERMS, ETC.: We are transmitting or delivering to you a copy of our software, similar to if we were transmitting or delivering to you a copy of a radio show. We own 
the original program, as an entire work, including but not limited to the coding, text, html, images, graphics, layout, design, and look and feel, all of which are COPYRIGHT by 
us, and all rights to which are retained by and RESERVED by us. Similarly, the source code including any and all parts which are based on our trade secret or any patented or 
patent-pending technology, are retained by us, and your right is limited to a right to use the object code distributed to you. You agree not to look under the hood, and to keep 
fully secret and confidential, even from your own eyes, all internal processes of the program.  
 
We grant you, and only to you, the right to use, for either a single user on as many machines used exclusively by that user, or for a single machine with multiple non-remote 
users. You may, of course, make reasonable backups of the program, if kept securely by you, and not in such a way that others might have access or the opportunity to copy or 
steal the program from your backups.  
 
You are  authorized  to  re-transmit or copy  the program  for your own use,  from a  fixed media  to another  fixed media or  to  local RAM of your machine,  in order  to use  the 
program in an ordinary fashion. You are not authorized to modify, crack, or hack the program. Application or implementation of any modification, crack, or hack, is a violation 
of this end user agreement, and a violation of the program's copyright.  
 
The the full extent permitted by law, no warranties are made, and the software is transmitted "as-is". Use of this software has not been tested by us on your individual machine or 
circumstances, and you acknowledge this and you agree to assume all risk of use. No warranty of fitness for use, and no warranty for merchantability are made by us, and ALL 
IMPLIED WARRANTIES are, to the extent permitted by law, fully disclaimed by us. To the extent permitted by law, the limitations of remedies for any breach of warranty is 
limited to replacement of the software, or refund of the purchase price, at our exclusive option.  
 
 
This product is distributed "AS-IS". 

  

 
 

    For more Ecco tools and add-ons, visit www.EccoTools.com. 

  

 
    Please share any comments, suggestions, or problems via: Feedback@eccoMAGIC.com. 

  

  

PLEASE NOTE: THIS HELP FILE IS EXPANSIVE, BUT IS STILL UNDER CONSTRUCTION   

  

  

 Help Overview: 

Introduction 

Adding content to a Viewpage  
 
        Adding clips to a MagicView page 
 
        Adding web clips directly to ecco 
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                'Specialty' Clips 
 
        'Exact' HTML content clips 
 
        Adding PDF and DJVU documents 
 
        Adding Links to other MagicView pages 
 
        Attaching the active MagicView page to the active Ecco item 
 
Sharing MagicView pages among items (Mirroring) 
 
Saving content 
 
        Disk/Ecco Page Storage Options 
 
        Saving a item's modified MagicView page 
 
        Attaching the active MagicView page to a new Ecco item 
 
        Copy Text to Child 
 
        Copy to Item Text 
 
        Exporting viewpage content 
 
Encryption 
 
Navigation Buttons 
 
Viewing & Editing content 
 
        Instant Zoom 
 
QuickView 
 
        Hotkey viewpage load 
 
History Menu 
 
Index entries 
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Viewing options 
 
        Attaching MagicView as an Ecco sidebar or viewpane 
      
        Instant MagicView Sizing 
 
Saving Graphics, formating, etc. 
 
Searching within Ecco 
 
        'Search and Replace' 

Private Notes 

 
How to click on hyperlinks in Magic mode 
 
Block Calc 
 
Technical options for 'programming types' 
 
When getting started with MagicView keep in mind 
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